No Sound After Fresh Install

I am running balenaOS 2.83.21+rev1 on raspberry pi 3, but unfortunately I do not have any sound. I can connect my spotify to it but when i try to play a song I do not hear any sound. All my balena-sound services seem to be running. Below is attached my log. Any help would be greatly appreciated.


esco-sound_dull-time-23.01.22_10_00_35_(+0000).txt (108.8 KB)

Same problem as you, I tried different speakers.

Same problem here on my RPI 4. Fresh install. I tried on 2 Pi’s both deploy and cli method. I know my headphone jack works as well.

Unfortunately I can not also connect to Bluetooth. It does not ask me for a Pin but rather give me an error that says “couldn’t pair with balenaOS f522 because of an incorrect PIN or passkey”

I have the same problem on a raspberry pi3b+. Sound system works fine. Spotify connect, bluetooth all shows me as connected and “playing”. But, alas, no sound. I even tried a older version of BalenaSound thinking it might be a bug in the latest version, but no cigar.

Outputting sound via headphone jack, logs shows that output as being selected. On reboot I hear a slight crackle in the speakers proving the jack to be powered, but no sound is coming through via bluetooth, airplay or spotify connect. Help greatly appreciated.

EDIT: This is a fresh deployment made today, As this is my first time trying out this project.
EDIT2: I actually managed to get it to work after making a few modifications.

Adding the following device variables and performing a full reboot seems to have fixed the issue.
Source of the variables found here: Customization - Home
I tried using RPI_HEADPHONES earlier with no success, So I cannot be sure if it was multiroom or audio output selection that was messing with me. I’ll test more at a later date.

AUDIO_OUTPUT RPI_AUTO All services
SOUND_MODE STANDALONE All services

Can you please share a screenshot what it looks like in your variables section? So multi room work work?

EDIT1: OK seems to work for me as well when I set the device variable AUDIO_OUTPUT to RPI_AUTO and reboot.

Do multiroom work aswell with the output setting set to RPI_AUTO?

Yes multiroom is working for me with RPI_AUTO

Same here, flashed from scratch a few times trying different things. Nothing worked. Seems to me the setting of the output card isn’t working for some reason, i.e. “AUDIO_OUTPUT” which supposedly defaults to USB > DAC > HEADPHONES > HDMI - DAC.

The following command temporarily fixes it, but you have to do it manually every time you boot up:

pactl set-default-sink alsa_output.usb-soundcard-1.analog-stereo

with “alsa_output.usb-soundcard-1.analog-stereo” being the desired output soundcard, in my case a USB soundcard.

On a side note, I’ve been experiencing a lot of instability with the system lately too (hence, the fresh installs at first). Laggy audio, connection losses (which kill spotify connect right away), etc. Hope these can get fixed as well :slight_smile:

Waiting on some official answer as to why this is happening, glad to find out I’m not the only one!

For the time being I’ll stick to Spotify connect on my TV, which works surprisingly well. No problems at all so far.

EDIT: Tried the RPI_AUTO setting on AUDIO_OUTPUT and it didn’t work on my setup :frowning:

Rpi 3
OS VERSION: balenaOS 2.83.21+rev1

Same here, flashed the newest version, RPi3. No manual config done.
multiroom-client throws some errors, pactl is not present in the system (tried in system’s command line.

Any hint?

I “think” I have the same issue. I’m new to balena-sound, and have deployed to an RPI4 with IQAudio DAC Pro. I’ve created the BALENA_HOST_CONFIG_dtoverlay = iqaudio-dacplus config item. I’m running 2.88.5r1 on the Pi. Any hints? I’m unsure of how to get a log file. Is that just going to ipaddress/support?

Hi everyone,

I’m new to balena-sound, and new to RPi to. I have deployed using “balea deploy” on RPi4, and had no audio. I tried a few workaround, and none seemed to work.
Here’s my setup :

  • Raspberry Pi 4 (using 64bit OS)
  • Host OS version: balenaOS 2.88.5+rev1 (development)
  • Supervisor version: 12.11.0
  • Intended output: jack 3.5mm
  • Audio source: Spotify or Bluetooth
    I tried modifying AUDIO_OUTPUT to both RPI_AUTO or RPI_HEADPHONES but none worked.

Here’s an extract of my log, if that can be of any help to debug this. As far as I know, it should neither output “WARNING: BCM2835 audio card not found, are you sure you are running on a Raspberry Pi?” nor “E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.”.

Any hints ? Solution?

 audio  --- Audio ---
 audio  Starting audio service with settings:
 audio  - pulseaudio 15.0
 audio  - Pulse log level: NOTICE
 audio  - Default output: RPI_AUTO
 audio  - Default volume: 75%
 audio  
 audio  Detected audio cards:
 audio  0 vc4hdmi0 vc4-hdmi-vc4-hdmi-0
 audio  1 vc4hdmi1 vc4-hdmi-vc4-hdmi-1
 audio  
 audio  
 audio  WARNING: BCM2835 audio card not found, are you sure you are running on a Raspberry Pi?
 audio  Setting audio routing rules...
 audio  Routing 'balena-sound.input' to 'balena-sound.output'.
 audio  Routing 'balena-sound.output' to '0'.
 audio  W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
 audio  E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
 audio  E: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="platform-fef00700.hdmi" card_name="alsa_card.platform-fef00700.hdmi" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
 audio  E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
 audio  E: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="1" name="platform-fef05700.hdmi" card_name="alsa_card.platform-fef05700.hdmi" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
 audio  W: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
 audio  W: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
 audio  W: [pulseaudio] module-loopback.c: Too many underruns, increasing latency to 205.00 ms

Hi everyone - so I have it still working with RPI_AUTO on one of my RPI 4’s out of the 3.5mm onboard jack however I’ve tried to add a IQ DAC+ to a second Pi this morning and no sound, have added the BALENA_HOST_CONFIG_dtoverlay and no luck. Hope someone can shed some light soon :frowning:

1 Like

I’m running into this issue as well. Hopefully someone will chime in and help us. :slight_smile:

Same problem here. Tried an rpi 3b, 3b+ and 4. None will make a sound. Even with the fix above it does not work. I tried installing 2.38 since that was listed as a possible fix.

Pasting some logs that may help debug

audio E: [pulseaudio] backend-native.c: socket(SEQPACKET, SCO) Address family not supported by protocol
audio W: [pulseaudio] module-loopback.c: Configured latency of 200.00 ms is smaller than minimum latency, using minimum instead
audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 250.00 ms
audio W: [pulseaudio] module-loopback.c: Configured latency of 200.00 ms is smaller than minimum latency, using minimum instead
audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 250.00 ms

Same problem, no sound at all, with fresh install of balenaOS 2.83.21+rev1 and 12.11.30 on Rpi3b+ with setting;
AUDIO_OUTPUT to RPI_HEADPHONES

Any news?

More testing today and trying every workaround I can find and still coming up with nothing. I am going to table this effort for now as there is sisters to be an issue that is out of our hands and must be fixed by the Balena team.

I’ve just tried to set up BalenaSound for the first time and I’m having similar issues as people above. Glad it’s not me just being a noob.

I get no sound from the headphone output, but am able to connect through Bluetooth, airport and Spotify connect. According to the console, the main issues appear to be with the multi room server and client. I’ve attached my console log.

Any help much appreciated. In the meantime I’ll try the fixes suggested here.

balena-sound_little-beach-01.02.22_22_43_50_(+0000).txt (78.6 KB)

Hi everyone, thanks for reporting the issue. I’ve just released a fix for this here https://github.com/balenalabs/balena-sound/pull/547 1, updating to balenaSound v3.8.4 should solve the problem! Let us know if it doesn’t, cheers!

1 Like

How do I go about updating to balenaSound 3.8.4? Under the pin to release modal I only see 3.8.2. I even nuked my pi and created a new device and am still on 3.8.2.

edit i deleted the fleet and created a new one and that was running on the new version. I still want to know how to update balenaSound without deleting the fleet.