balenaSound - sound not working on Raspberry Pi 2 out of 3.5mm jack using Spotify

Please help! I just switched from Volumio to give balenaSound a try. I have a raspberry pi 2 Model B. I flashed the SD card with the appropriate OS (balenaOS 2.48.0+rev1) then pushed the latest balena sound repo using the CLI tools. I was able to create an application, add the device and everything.

I see that the Spotify service is running via the dashboard and I am able to use Spotify Connect to connect using my phone no problem. The music appears to be playing but no sound is coming from the speakers which are plugged into the 3.5mm port. Just the day before I was using the same raspberry pi to play music using Volumio through the same speakers so that’s not the problem…but I did plug in some headphones just to be sure and still no sound.

I don’t have HDMI plugged in so that’s not the issue either. I tried setting RESIN_HOST_CONFIG_hdmi_ignore_edid_audio to 1 to force sound through the 3.5 jack but that didn’t make a difference.

I couldn’t find anything else on the forums about it and could really use some help!

Hey @jhaywood welcome to the forum!

After seeing your post I’ve just deployed a brand new app with a Pi 2 just to check all is working as it should be, and it seems to be OK. Could it be that the volume has been turned right down?

If not, first, let’s disable multi-room audio by setting the DISABLE_MULTI_ROOM environment variable to 1, this just simplifies things whilst we test.

Next, open a terminal to the ‘spotify’ container and run install_packages alsa-utils. After that completes you can run speaker-test -c2 -t wav to test the output. You can also use alsamixer to check the volume levels if you’re still not hearing anything.

Keep us posted with your progress!

That worked!

I set the DISABLE_MULTI_ROOM environment variable and then installed the package to test the audio and sure enough I had sound. I then tested Spotify and it worked beautifully. It’s weird that disabling multi-room seemed to fix it but I’m not going to complain. Thanks for the help!

1 Like

Hi, what is the balenaSound version that you deployed?

It is balenaOS 2.48.0+rev1.

@jhaywood thanks for confirming that worked! Multi-room should be disabled by default on the Pi 2 but isn’t at the moment so I created an issue here: