BalenaSound - issues playing audio after initial setup

Hi there

I’ve just attempted to set up a BalenaSound project using a single Raspberry Pi 4B, with the intention of expanding to a multiroom audio setup. I’ve followed the setup guide and flashed the RP, which shows up in my Balena dashboard. However, I’m unable to hear any audio.

I am able to connect to the RP via bluetooth, Airplay and Spotify Connect, and according to Spotify, the audio appears to play. I’ve tested using the headphone jack and checked that my amp is working and properly connected.

The console output appears to show some issues with starting the multiroom server and multiroom client services, which I’ve attached (apologies, there is rather a lot of data).

Thanks in advance for any assistance you can offer!

balena-sound_little-beach-01.02.22_22_43_50_(+0000).txt (78.6 KB)

Saw your post and wanted to give you a heads up that there appears to be a problem, a lot of people are experiencing the same thing. Here is another thread about it. No Sound After Fresh Install - #17 by Syco54645

Thanks for pointing me in the right direction, I somehow missed those. I’ll add my comments over on that thread.

No problem and good luck!

1 Like

Hi everyone, thanks for reporting the issue. I’ve just released a fix for this here https://github.com/balenalabs/balena-sound/pull/547 1, updating to balenaSound v3.8.4 should solve the problem! Let us know if it doesn’t, cheers!

1 Like

Thanks, that’s solved the issue.

Excuse my ignorance but how does one update balenaSound? In fact where can one check the current version of balenaSound? Not finding this in the docs anywhere.

I completely deleted my balenasound fleet and started from scratch, which gave me the latest version. I only have a single device currently, so this might be less practical if you have more. Hopefully someone with more knowledge than me will be able to advise on how to update in place.

If you go to your balenasound fleet, and go to the Summary tab in the bar on the left, what version is shown when you click the dropdown in the Releases window? And if you go to the Releases tab on the left, what does it show under version?

Thanks for the response.

When I click the dropdown on the summary tab I see 2.8.2

On the releases tab it also shows 3.8.2

I ended up deleting the fleet and that fixed it. Wish I could find documentation to describe how to do it without deleting the fleet.

Already replied in another thread about updating, copy pasting here:

Basically your fleet only sees 3.8.2 because it’s the only release (or the latest) that you pushed to it. You need to create and push a new release to your fleet. To do that you can use the same deployment method you used initially. There are two main methods to deploy: one-click (using the deploy button) or cli (running balena push cli command). Here is a description and guide for both: https://github.com/balenalabs/balena-sound/blob/master/docs/01-getting-started.md. If you try the “one-click” route just be sure to do as Nico said and deploy to your existing fleet rather than creating a new fleet (you’ll get a modal pop up that will let you choose).

Wish I could find documentation to describe how to do it without deleting the fleet.

Point taken! I created an issue here https://github.com/balenalabs/balena-sound/issues/549 and will add relevant docs to fix this. Thanks!

1 Like

Thanks tmigone, that’s helpful to know for future reference.

Syco54645, glad you sorted it out. Now we both know how to do it properly in future!

Thanks! This will be helpful in the future for others.