Newbie problem with Bluetooth not showing for Raspberry Pi4


Have just added 2 Raspberry Pis to Balenacloud(both 4s) and they don’t appear as Bluetooth devices neither from my phone or laptop. (Balena OS 2.75)

#systemctl status bluetooth

Gives me “running” on both units.

Am I missing something obvious?

Thanks in advance.


Ok, so I run discoverable on and enter ‘yes’ and it pairs!

But…no sound when I play something from my mobile phone?

Hi, can you tell me more about your project? Is this in regards to the balenaSound project?

Yes it is the BalenaSound project. What logs would be useful?

What kind of speakers do you have connected? Have you tried connecting your phone directly to the audio jack to make sure the speakers are working?

Once you’ve verified the speakers are working, you could look for anything suspicious in dmesg as well as the system logs journalctl --no-pager -a

If nothing is immediately obvious, you can post the device diagnostics by going to the device page, diagnostics experimental, run diagnostics and post the logs here.

You will have to change the .txt extension to .log to post here though (I believe this is changing though if it hasn’t already)

Thanks for your bearing with me zwhitchcox.

I’ve tested the speakers on my laptop and they are fine. Before installing balena I had the Pis running raspbian and the speakers were fine then on that OS.

I guess I have 1 major issue here. Basically neither of the Pis is appearing automatically when I run a bluetooth scan either on my Samsung J4 phone nor when I scan on a macbook. I have some bluetooth headphones and speakers and these are picked up fine.

Dmesg comes up with these errors in red:

[ 8.132137] bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
[ 8.137474] bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
[ 8.486143] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 8.502393] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 23 2020 02:19:54 version 7.45.206 (r725000 CY) FWID 01-88ee44ea

[ 12.076532] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save disabled

And journalctl --no-pager -a comes up with 1 message in red:

May 13 14:57:10 f64cfbf sshd[7580]: error: Unable to load host key: /etc/ssh/hostkeys/ssh_host_dsa_key

Attached are the logs from one of my Pis.

Best Regards,

f64cfbf7db9d4e30398fafedee2be1a3_diagnostics_2021.05.13_14.57.58+0000.log (450.1 KB)

Have tried a Google Pixel phone and I get exactly the same issues. Can pair with the Pis but can’t play anything out of them when I go on youtube for example. The audio goes through the phone, just like with my Samsung Galaxy J4. Here are the logs from the Pi:

[NEW] Device 58:24:29:6E:63:B2 Pixel 4a
Request confirmation
[agent] Confirm passkey 954401 (yes/no): yes
[CHG] Device 58:24:29:6E:63:B2 Modalias: bluetooth:v00E0p1200d1436
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001105-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001112-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001116-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000111f-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000112d-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 0000112f-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001132-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001800-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device 58:24:29:6E:63:B2 ServicesResolved: yes
[CHG] Device 58:24:29:6E:63:B2 Paired: yes
[CHG] Device 58:24:29:6E:63:B2 ServicesResolved: no

Anyone any ideas?

This is the document I’m using:

Ok so I understand that I need to install both balena cli and balena sound.

I seem to have the cli installed ok (output below) but what command do I need to install the sound software from github?

balena pull or…???

root@f64cfbf:~# balena --version
Docker version 19.03.18, build 840aacc77b6c600b3b929fe9e4d9356a322b9e5b

Hi there! If you have followed the guide you posted the link to ( Getting started - Home ), and you used the method detailed in the “one click deploy” section, then you won’t have to use the CLI, everythin gets handled for you. As you seem to already have balena sound running on your RPi4, you already have the application deployed.

About your issue - as far as I understand, you can connect to the RPi4 via bluetooth, but when playing a youtube video from the device you have connected with (phone/laptop/etc), no sound comes from the speakers that you have connected to the Rpi4 (speakers that we have verified to be working by testing them with another device).

Can you play sound on your Rpi4 balena sound setup when using any of the other methods of operation that are supported, such as airplay or spotify connect? Also, be aware that there may be a delay between starting audio and then hearing it come from the output. You can also look at this page which has several troubleshooting suggestions - you could try the workaround suggested at the bottom of the page for no sound output for rpi3 64-bit OS, just to see if that works Support - Home

Additionally, you could experiment with some of the configuration options: perhaps trying to increase the volume, or force the output to be HEADPHONES


Thanks rcooke-warwick. Any reason why I am not getting any services listed? Surely this has to work first or…?

Hi there, is your device provisioned with the balena Sound app, and appears in the dashboard with the various containers running?

Yes, I’m testing with 3 raspberry Pi 4s at the moment and none of them show services but they are all in the dashboard and I have command line access to them.

ok, I understand. Did you use the deploy with balena button on this page to create the application? Getting started - Home

Oh, definitely. I’m always for the easiest ways of doing things!

Hmm, and despite this, the services haven’t been downloaded? That is strange. Basically, if you create an application with that button, and then add a device to that application, then the device should automatically download and start running all of the containers/services.

In my applications tab I don’t have that option.

I meant that if you click the deploy with balena button that is on this page: Getting started - Home then you will be prompted to create an application called balena-sound

when created, if you add devices to that application, they will then automatically download the balena-sound software