BalenaSound Bluetooth Host invisible/inactive

I installed BalenaSound on my Raspberry Pi 3B+ and everything worked fine. The status for every service is shown as online in the Dashboard, however I cannot see the Raspi as a Bluetooth Device (I tried multiple clients, it must be the Raspi). The other services such as Spotify work flawlessly.
I hope you can help me out.
I also granted Support Access (c4b4364d58ab25633f53f497cfe32b6d)

Hello, in the logs it looks as though it should be making itself discoverable. It may be worth disabling multi-room and then seeing if it shows up. Also if you haven’t already, try to move your device closer to the rpi and see if that makes a difference.

I tried several different approaches and even Operating Systems and the issue remains the same. At this point I believe it might be a hardware issue.

Hello, it does sound like a hardware issue if the problem persists across OS’. Maybe you can try with a USB bluetooth dongle if you have one? Let us know if you figure it out.