Etcher Opens to a Blank Screen

I downloaded the latest version of Etcher on my Win10 Pro machine and it opens to a blank screen. Opening as Admin does nothing and running portable version also does nothing.Error.log (20.6 KB)

Looks like it could be a bug. Could you open an issue in Etcher’s github repo with your OS version and that error log attached?

Hi, I also have the same problem with Windows 8.1
I disabled antivirus, that did not help, then I excluded the etcher file name from antivirus scanning and that did not help.

Hi there @apddad1 – we’re tracking this bug here, and we’ll update this thread when the issue is fixed. If you’re able to post details of the problems you’re encountering on that issue, it would be appreciated.

All the best,
Hugh

Having same issue with MacOS. Thanks!

thanks hugh, I’m a newbi to etcher, today was my first experience, so I’m not to the point where I could add anything. I would think this would be easy to replicate. btw, I’m running Windows 8.1 with all the latest patches and Mcafee antivirus.

Hi ,

I ran in to the same issue and I think I found a workaround. It appears that the Etcher program does not like my SD card reader. The work around was that I turned on Etcher without the SD card reader attached and then I selected my disk image file (.img), next after selecting the image I get to the disk part of the wizard and of course it cannot find my disk, so hit “continue”, now plug in the SD card reader with the SD card and it should auto detect the card and select it for you.

Thanks for the additional info billybob71a , the team is investigating the issue and hopefully will have a fix soon

what i noticed is, that etcher works normally but as soon as i stick in a usb stick and the windows notification comes up, etcher goes blank…
I tried on my laptop (nvidia + intel graphics) and on my PC with only nvidia graphics with the exact same results:
etcher works fine as long as i do not insert a usb drive.

It looks like there might be a fix for this as seen on the github issue: https://github.com/balena-io/etcher/issues/3160#ref-pullrequest-622331470 so hopefully we can get that out soon.

I confirm the issue on my Win10 Pro, when the sdhc card is still unplugged, the software starts as expected, but when the card is plugged even after the starting , the screen becomes blank.!

Hi, the fix has been released now in v1.5.91. Can you please check it out and see whether it is working for you now.
Thanks,
Zahari

Yes, the release 1.5.91 fixes the blank screen issue

We are glad that everything works as expected! :muscle:

also1.5.91 fixed on Windows 8.1