Blank screen after installation on Windows 10

Hello,
I have downloaded the balenaEtcher-Setup 1.5.56 for Windows 10.
I have install it with administrator rights.
By running it I only have a blank screen.

I have tried to re-download and re-install; always have a blank screen.

Is there any solution?

Hi,
Can you try pressing Ctrl + Alt + I while the window is focused and send us any interesting logs that appear in there?
Could you also check whether the portable version has the same issue for you?

Hi,
Ctrl + Alt + I —> nothing happens

Portable version has the same problems Blank screen and no logs by Ctrl + Alt + I

Oh sorry my bad, the shortcut for the dev tools is Ctrl + Shift + I.
With that open, you can then do Ctrl + R to reload so that we can get all the logs.

Can you also try to start etcher as a administrator, just to check whether this is a permissions related issue.
Also, have you been able to use an older version of etcher without facing this issue?

now I can get the DevTool but always get the same message by reloadig

I always run it as administrator.

I had an older version runnibg on another PC with Windows 10 and it worked perfectly.
It was last year and I don’t remember wich version it was

Hi, can you try reloading (ctrl + r in the DevTools) with the Console tab focused? There you can also enable logs persistence in the Console settings, which will keep logs even after the reload