Etcher killed my USB stick

Sorry, I might have misunderstood.
You tried to flash an SD-card with an image you had on a USB stick but instead of flashing the SD the USB stick was modified and does not show up any more ?
Are you sure you selected the right target device? This sounds like you might have flashed your USB stick…

Hi, it wouldn’t have been possible for me to flash the USB stick as the raspbian image file was sitting on there. I was flashing the SD card with the raspbian image so I can use it with my pi.

USB stick (with image file) --BalenaEtcher-----> SD Card

However, the flashing was interrupted abruptly (which may have been due to an error on the image file, but it killed the USB stick.

I hope that makes sense.

Hi, you can follow https://www.pendrivelinux.com/restoring-your-usb-key-partition/ to re-create the partition table. For example, using the cli in windows they mention in that link that you would do:

Manual Method via Diskpart – Windows:

Open a command Prompt as administrator (cmd.exe)
Type Diskpart and press Enter
Type List Disk and press Enter
Type Select Disk X (where X is the disk number of your USB drive) and press Enter
Type Clean and press Enter
Type Create Partition Primary and press Enter
Type Active and press Enter
Type Format fs=Fat32 Quick and press Enter
Type Exit and press Enter

Thanks to System 76 for barely compiling an installation guide, not to mention any useful FAQs or troubleshooting. I have a couple friends who play with Linux distros in dev and this is the 4th time I’ve been asked to repair a USB. And guess what? All 4 times were instances where the person used Etcher, as instructed, to flash System 76’s POS/POP OS and after successful installation of the OS, as I’m told, the drive is unusable, unable to be cleaned in diskpart, unable to be formated, etc. I’ve always been able to work around diskpart in WIN10 to success but this SANDISK 32GB is not having it. I keep getting the message along the liens of “Cluster Size too small” …here’s a couple lines from my Event Viewer:

Cannot zero sectors on disk \?\PhysicalDrive2. Error code: 5@0101000F

I’ve tried my PC, running WIN10 with 16GB RAM and a couple SSDs and my 2 laptops. All 3 provided the above error in event viewer. Can anyone help me out? If not I’ll just trash the hell out of this software all over my XDA/reddit and personal forums so that hopefully people will stop asking me to fix something that, had I been the developer, I would have fixed A LONG TIME AGO.

Here is a solution you can try (double cleaning with diskpart): https://github.com/balena-io/etcher/issues/1991#issuecomment-361077474

Hi all!

I found a quick workaround on Mac OS X (Catalina):

  1. Open Disk Utility;
  2. Create an empty image file .dmg (File > New Image);
  3. Set the new image size as the original USB size (check the available capacity on disk);
  4. Select the filesystem you need ( I used ExtFAT for my needs)
  5. Open Etcher;
  6. Select the freshly created empty image as the source, and the “dead” USB as the target;
  7. Burn it;
  8. Delete the empty image on your computer.

Now the key is recognized again under Mac/Windows/Linux.

Cheers,
Simon

I recently used a USB stick as a boot to install the latest Pop!_OS 20.04 LTS and everything went well. But it seems like after I was done flashing the popos iso onto my USB stick, it seems like the windows 10 cannot find the USB anymore even though its plugged in, i know that etcher delete the exisiting partition and make new ones to download the iso(correct me if i am wrong). The disk management seemed to know that the disk is there but when i try to change the driver letter or format the systems just tell me it cannot find the file specific. I have tried using the MiniTool Partition Wizard to wipe everything on the USB, format it and create new partition, it does show up after the above steps. But once i eject the usb, it reverts back to being unable to be use or open again.
This issue is only on window 10, it seems like i can access the usb when i am on Pop!_OS, so I am not sure why.
Please help.
Thank you

Your USB stick is not damaged…It’s just that the Linux Mint ISO is creating partitions for making it bootable (for UEFI). It does the same on other OS installed on Legacy.

Hey man, thank you. This thing actually fixed.

Actually, did you see that when you try to etch windows it gives a warning saying that it needs special processing to be made bootable? Linux Mint is similar to Windows, its code also needs the special processing.

i have your same usb and the same problem occured to me, can you please help me and tell me how to fix it?

My analyze is that my problem was actually not that flashing had failed. My problem was that when I after flashing checked the USB-stick in macOS File manager, I could not see all files. But that is because macOS do not recognize “Linux files”. So now afterwards, I believe all was ok. I have used Etcher several times later on macOS and flashing has worked, although I cannot remember if I have done it on that particular USB-stick. When I don’t flash with Etcher, I have used the flash software coming with the Linux Mint installation, in Linux. If you have the possibility to check your USB drive in a Linux OS, then you should see also the files from “Linux file system”. Hope this helps.

Do not use Balena Etcher it broke two of my USBs sticks. I recommend using Rufus as that works for me and DOES NOT break my USBs stick as I have used both Balena Etcher and Rufus. The reason I used Balena was that it looked simple and easy to use. Although true it simple and easy to use it will inevitably break your USB making it not worth your time and money. I did a lot of research and have not found a solution to fixing both my USBs. I hope your USBs get fixed from this terrible app. Have a good day if anyone reads this.
Edit: FOUND FIX
what u do is u download any iso file which i downloaded pop os iso and i downlaoded rufus again
Step one: download Rufus
Step two: download any iso file
Step three: Plug in ur usb
Step four: select ur usb and iso in rufus
Step four: keep default and start
This will reset the USB and download the iso files which then you can go to the usb and deleate the files you downloaded making your USB drives usable again.
If you dont understand just look up how to download iso to rufus on youtube, do it, then deleate what you downloaded to your usb and that should fix it. I hope you can understand that if someone don’t understand help them if u understand cuz i can not explain any further. Also might make a youtube tutortial using notepad to explain what i am doing in my tutorial. Check my yt (TA OGboy) because I might do the tutorial over there for the people who dont understand the steps i put out. Have a good day if u understand my terriable instructions cuz i know i am :).

Hi Gavin, sorry to hear you were having trouble with Etcher. The steps you describe may certainly work, I have not attempted to duplicate your work. But, you can also try some of the tips located in this blog post, which might be a little bit easier: https://www.balena.io/blog/did-etcher-break-my-usb-sd-card/