Etcher killed my USB stick

Used the version 1.4.4 of Etcher to burn linux mint ISO and the software reported that it had run and completed successfully but of course not only did it not burn the image, it also bricked my USB stick and it will only format as 2.2MB even though as of last week it was a perfectly working 128GB stick. I got the same error as the guy below who was trying to install Mint and got an efi folder and nothing else. Don’t use this software to burn a mint ISO. Thanks for nothing guys.


I was able to re-partition the drive to recover the USB stick.

Still don’t recommend this software.



exactly same thing happen to me
it turned my usb into 2.2mb , with only efi folder in it

able to re-partition the whole usb to recover

anyone know whats wrong?

1 Like

Same happened to me. USB-stick was killed when flashing Mint 19. Etcher 1.4.5, macOS Mojave 10.14.

I’m still trying to bring my USB back alive to be usable again. Failed in my initial trials (on Windows).
How did you do to recover the stick? OS, Tool, command, settings? Thanks for any advice.

1 Like

Apparently they have no answer for this. What good is having a forum if you are not going to participate in the conversation? I have been using this type of software for 30+ years and have NEVER had one that borked the partition as bad as Etcher did. Totally WORTHLESS software and I will NEVER use this poorly designed software again! Only value it has is it was free and I did not waste any money to find out how useless it is!

1 Like

Hi, we are checking this out, and keep you posted. We don’t expect anything like this to happen,

Any more information on the USB stick that you used @hehemrin ?
Any more info on your environment, and storage device used, @kevinmo?

1 Like

I was using Kingston DT50 (DataTraveler50), 16 GB.
Happy news: I have reflashed the stick, and also tried and selected another way to boot the live-stick, and now I actually got it working! So, maybe it was just my mistake/competence in how I managed the boot options in my first trials. So for my case, you can close it as solved/no issue.
(By the way, I understand now (hope correct), that when checking the USB stick in Windows or MacOS, they will not recognized the “Linux part” or the stick; they will only see the boot part (efi-folder).)

1 Like

@hehemrin yes, that last observation is very much correct - Windows sees much less than Linux and OSX devices. That was likely the issue, that on Windows you can’t always check if the end result is correct because of this.

Most of the time reformatting the disk with another tool should do the trick to put back your stick into it’s original - Windows-usable - state. (Windows prefers FAT or NTFS partitions, I think)

Thanks for the update, and glad things worked out!


Hello I also have the same problem, and it seemed that I had solved it until etcher told me this error when I wanted to burn the iso.

Hi @Sunk1911 ,
Is the source image (tahr64.iso) located on an external drive by chance?

Same thing happened to me. It bricked 4 drives. Use Rufus instead it works every time. I only tried this software because Proxmox said to use it. Never again.

Can someone please tell me how to get these drives back?

Hi @Big ,
We can look into it if you’re willing to share more info on your issue! Like the image you tried to flash, the model of the drive, the version of balenaEtcher you’re using.
Meanwhile, to try 'n recover your drives you can try one of the solutions we listed here

So far, I have not been able to recover mine. I’ve tried everything, it’s getting worse.

Same here, altough it didn’t kill a USB drive. It put 2 SD cards in write protection mode. One of which was brand new. Fix your software, because it sucks. Win32DiskImage works.

Also, when you unplug a USB device the whole Etcher screen turns white and stops doing anything. I even had this happen without unplugging or plugging something back in.

Hello !
I have the same problem here with one of myUSB drive. Tried to flash “linuxmint-18.3-cinnamon-64bit” on it and it completed with no error. Now when I plug it on one of my computers the drive lights up but I can’t find it anywhere. I literally can’t do anything on it.
I tried before with another one and got the 2MB problem but I solved it…
Anyone has any idea on how I can bring the first one to life ?
Thank you. :slight_smile:

It locked my micro sd card and now I can not format or delete anything from my micro sd card.
I flashed the Raspbian image which created 3 partition on the card after successfully completed the flashing I can not do anything with the card.
Is there any solution to fix my micro sd card?
Please help.

Yup. Ruined 2 of my USB sticks this morning. I am going to report to Microsoft so they can put this website into their filters as a dangerous website.

1 Like

Saw the same thing as everyone here described, but if you stick the USB stick into the PC to be installed, everything boots right up. Windoze doesn’t recognize Linux file systems so it only sees the boot partition.

USB Drive: SanDisk Ultra Fit 128GB USB 3.0 Flash Drive - SDCZ43-128G-GAM46
ISO FIle: linuxmint-19-cinnamon-64bit-v2.iso
Host OS: Windoze 64

1 Like

Kevyn if that is true then I feel like a fuk’n noob for ever bringing it up in the first place because the explanation seems like maybe it is plausible but linuxpendrive for example does not have this issue.

@brandonbvisi, @Flowers

I also had the same problem. and have a simple solution to recover your USB. This will remove ALL information from the drive and render the data irrecoverable

Within Windows access the command Prompt
“diskpart” - this will likely open another window
“list disk”
“select Disc X” - select the disk you would like to fix
“detail disk” - gives you the rundown on the selected disk (just to double check yourself!) ** note the volume number**
“delete Volume X”
“create partition primary”

edit: For one device I still had to remove the USB drive, re-insert it, and then have Microsoft format the drive before it would be usable :end edit

That should get your USB back up and running after.