consistently creating unreadable USB drives

I have tried for over a week now and I cannot create a useable USB stick. I have downloaded at least 5 different versions of Linux and keep getting the exact same results. It will flash, verify, then it comes up with disk is unreadable and the more info states the checksum does not match for range [0,3071936643]. this is on my M1 Mac running OS 12.0.1 Monterey. each time I have created a dvd after the Balena failed and it successfully made a bottle dvd and I could run the live Linux and Ive installed from the created DVD so I am confused as to why this is happening. I have screenshots but I do not know if I can attach them. Thank you for any help

Even if verification failed, did you attempt to boot any of those Linux USB sticks? Did they work? Sometimes, Windows or Mac will write some small temporary / hidden folders to drives upon completion…and if that occurs prior to Validation completing, then the checksum will not match. However, the resulting USB stick does indeed work fine in most cases. As a side note, if you write a Linux USB stick, but then attempt to read that stick back on a Mac or Windows machine, you most likely will not be able to read it’s contents, as the linux filesystem is incompatible. You can certainly delete the partition and reformat it back to Windows, but figured that might be worth mentioning as well. Thanks!

Yes, not only did I try to boot with them I actually tried to read them from a system running Ubuntu Linux and all that failed show unreadable

Strange - we have tested on the M1, but I wonder if that has anything to do with it. Any other machines you can install Etcher on and make another attempt? Alternatively, have any other USB sticks laying around that you can try, as well?

I have my 2014 Mac Mini I’ll install it on and run a few tests. I will also try some different usb drives and will let you know.

Great, thanks!

Ive spent a couple days now troubleshooting this, here’s what I have done and the results;

Equipment:

  1. 2021 M1 24" iMac with 16GB RAM running OS12.1 Monterey
  2. 2014 Mac mini with 16GB RAM running PS11.6 Big Sur
  3. 2009 MacBook Pro with 16GB RAM running Linux Lubuntu 18.04

All testing was with the latest balenaEtcher 1.7.3

First test;
On the M1 Mac, I downloaded Ubuntu 18.04 and ran Etcher, upon completion the Mac stated the disk was unreadable. I then ejected the USB drive and plugged it into the Macbook running Lubuntu 18.04 to see if that system would read the drive. It would not recognize the drive. I then plugged in a blank USB drive of same type and that it opened up of course empty. I then repeated the entire process with a PNY USB drive, successfully completed the Etcher process however still same unreadable drive both in the host Mac I burned it with as well as the MacBook running Linux.

Second test;
On the 2014 MacMini, I installed the 1.7.3 version of balenaEtcher which had not problem installing. I then repeated the burn of Ubuntu 18.04, upon completion, the Etcher showed a successful completion however the MacMini stated the drive was unreadable. I then took the drive and plugged it into the MacBook running linux and this time the drive did show. So then I attempted booting the MacBook with the new drive and that also was a success. I then tried the failed PNY USB drive in this MacMini and again the result was a successful burn although the MacMini stated the drive was unreadable. I took it to the MacBook and it successfully read and booted from the PNY drive.

Third test;

I decided to take the successful PNY drive and repeat the test using the M1 Mac, after Etcher had burned the Ubuntu onto the drive, I got the Mac cannot read drive error, which, I expected. I then tried the drive in the MacBook running Linux and it failed to read the PNY drive.

My conclusion is for some reason balenaEtcher will not work with my M1 Mac. I can get around that by using the MacMini since I have that available. I will watch closely to see if there is any updates to Etcher and I will try it again but for now, it just won’t produce a readable drive from the M1 Mac running OS12.1 Monterey.

Thanks for the support I look forward to future version and hope I can use it on my production M1 in the future.

@mcraa - Do you have a Mac M1, by chance?

No @dtischler, I don’t have any Mac. :frowning: