Failed device check sum

Hi so i’ve been trying to burn manjaro iso file to the usb using etcher but i always got this error message: Checksum doesn’t not match in range …
Im using Macbook air mid 2013 mojave any idea on what cause this?

Hi there. I think that we should perform some checks to identify where the problem is coming from. Could you try:

  1. flashing the same image to a different USB stick/SD card
  2. flashing the same image to the same USB stick on a different USB port
  3. Try flashing a different image

This will hopefully point us at what component is creating the error!

So have tried 2 and 3 can’t try 1 because almost all usb is broken. When i tried to flash it says this Screen Shot 2020-05-28 at 17.29.36

Hello, without trying with a different USB stick we can’t verify that this isn’t being caused by something hardware related. Was this the message presented when flashing a different image/using a different USB port, and are you still getting the checksum error?

You could try running etcher with sudo, some mac users have reported that this helps.

Tried different image and usb port still getting the checksum error, Ill try using sudo if that doesnt work ill buy an new usb. Also any guide on how to use sudo?

From the terminal application, you can run sudo /Applications/