Flashing Linux help

I’m trying to flash Ubuntu onto a flash drive (duh?) in order to boot my laptop with linux. Once the etch “finishes” it gives me some conflicting messages

  1. “Flash Complete”
  2. “Failed target ‘checksum does not match for range’”
  3. A system message telling me the flash was completed
    I have tried 3 different USB ports and 2 different flashdrives and at this point i’m not sure what to do.

I flashed Ubuntu, failed twice using 128 GB flash drive on two different machines. Switched to 8 GB, which is closer to the size of a DVD, and it worked fine. Experiment with 16 GB and 32 GB and it might work. If you get a message saying that the Flash drive is big, then it will probably fail.

The drives being of different sizes have nothing to do with it. What’s expected to work on an 8GB drive is also expected to work on a 128GB one.
What version of the application are you using and on what OS?
In case it’s Windows, there can be false positives as it tries to create the System Volume Information folder that can lead to checksum mismatches.
Regardless, since it happens on different equipment, it’s unlikely that there are broken sectors on all of the drives, a fair test would be to use a different reader (or different ports) with different targets.
You can try the media you just flashed as a final test.

Running the latest version downloaded, on windows 7 professional and windows 8.1. I suspect that the application copies the file then fills in the remainder with all ones or zeros, like what used to happen on older systems. Therefore the mismatch occurs not on the application data but on the attempt of the application to fill in the whole flash. It’s possible that if there were no verification cycle, it might work. This is easy enough to prove, just keep upgrading the size of the flash drive until it fails.