Flash Failing on multiple USB Sticks..

Hello, I am trying to make a bootable USB because I want to try out Linux but the flashing process keeps failing after verification. I’ve tried different USB sticks, different ports, hell even differents ISOs (Latest Garuda linux and Manjaro KDE, to be specific) but all of them keep failing. I don’t know what could be causing this issue, any help would be greatly appreciated!

Also, I am on insider version of Windows 11

What version of balenaEtcher are you using? What error do you see when the flashing fails? Do post the errors on the thread.

I am using the 1.5.122 version of balenaEtcher. I get no error other than Flashing Failed after verification

Edit: I tried flashing on my other laptop which has Linux and I used the latest balenaEtcher but it still failed to flash.

Hello @vinilshah welcome to the balena forums.

Could you please open the Etcher Developer Console (like the browser developer console, on mac i use Cmd+option+i) and check the error logs there?


Forget about Etcher. I had the same problem than you with Win11, check my post below yours. Etcher unable me to flash any linux distro and blocked my usb flash drives.

You know how I could fix that blocked drive and flash the distros? With a free win utility called ISO2Disc.

Today I made a last attempt to use Etcher and always errors and blocked usb drives. I used that other utility with both Kali Linux and Zorin Linux in the same usb drive and worked great.

Though I used to be a fan of Balena Etcher before, with Win11 it is not worth it.

Hope it helps.


Hello guys, sorry took too long to respond but apparently even after balenaEtcher said the flash “failed”, I was able to boot into the USB just fine, even installed Linux and everything worked just normal. Thank you for all the suggestions!

1 Like

Hi, have you tried turning off Controlled Folder Access or disabling the live protection (just as a test, you can put an exception there if it works)?