Flashing Linux Mint iso onto a flash drive (Mac OS Catalina) Failed

The error message when I hover is: “/dev/disk2: Source and destination checksums do not match: cfaa0f335f30aa77 !== d9a6fdfb0001372f”

Tried different flash drives, tried moving ports. Same results for over an hour. Your help will be greatly appreciated!

Hey there! Sorry to hear you are facing issues! That error message means that while Etcher correctly flashed the image into the drive, the resulting drive doesn’t contain the exact data that it flashed to it (i.e. some bits might be flipped), and its complaining a safety measure.

This usually happens due to low quality SD Cards, faulty USB ports, electro-magnetism, etc. Are you using any sort of adapter on the USB ports?

Yes, I am using an adapter because my macbook only has usb c ports. What do you suggest I do?

HI Nathaneal, what make of SD card are you using?

I am using a usb flash drive from HP.

Do you have another flash drive and/or dongle you can try?

I think the problem is the dongle. I’ll try another and let you know after. Thanks!


Did you have any luck on this when you changed dongle’s?


If you are trying to install an ISO to a thumb drive or similar, you will first need to convert the ISO to an image file on OS X.

For ease of use, copy your ISO to the desktop. Open terminal and copy this:

hdiutil convert /Users/Computername/Desktop/imagefile.iso -format UDRW -o /Users/Computername/Desktop/convertedimagefile.img

Replace Computername with the name of your Mac. If your ISO for example is named Linux10.iso then the converted image file will be called Linux10.img in the text above.

Yes, sorry for the really late reply. Change the dongle, and it will work as intended.