balena ruined my micro sd

hi
after flashing my micro sd with balena and Raspberry Pi OS (32-bit) Lite the card cant be seen or formated
windows says it can not formated
please help
thanks

Hey Nikos,

Rapsberry PI OS is a Linux system and cannot be read by Windows, so don’t worry, it might not be broken at all.
In this article you can find more info on what happened, and how to create new partitions (re-use) your SD card:

get back in touch with us if you need more help

Regards,

i formated it with android phone, windows still doesnt see it
how can i reinstal with baleno?

Hello @nmouts,

Have you tried with the instructions in the post that my colleague shared?

We’re a bit lost on what you mean by “I formated it with Android phone”. Could you share the steps you followed to flash the SD card?

Cheers,
Nico.

after windows couldnt see the micro sd (after the baleno) i inserted the micro sd in an android phone and formated it
now its visible in windows as an only 30 mb drive

Hey there! Keep in mind that depending on what you flash on the drive, Windows may be able to see the partitions or not. For example, if its a Linux based system with Linux-based partitions, then Windows will not be able to read them by default, unless you install custom software/drivers that allow Windows to mount Linux partitions

do you know any way for windows to see linux partition?
i followed the link’s instructions it still sees only 30 mb

Do you know that type of partitions that drive has? https://www.diskinternals.com/linux-reader/ seems to support a decent list of Linux & macOS file systems

Hi @nmouts,

I’m assuming your SD card is not failing physically. There is no software that can physically damage hardware.

The Raspberry Pi runs a Linux operating system (usually), and Windows cannot read some types of file systems for Linux. So when you flash balenaOS or Raspberry Pi OS on your SD card, it will write multiple file systems (partitions) that Windows cannot read. When you insert that card into your Windows computer’s card reader after flashing it, Windows will pop up alerts that it can’t read the partitions and will want you to format them. Just dismiss those pop-ups without Windows doing anything to them. You will only be able to access the one partition on the SD card that Windows can read (which for balenaOS is 32 MB in total size), and that is the one you may need to access for updating configurations on your RPi.

The issue you saw by trying to format the SD card in your Android phone is actually a “problem” with Android, not your card. Android can read the Linux partitions. But it cannot properly format a SD card that has multiple partitions on it. Android will only format the first partition it finds, resulting in the appearance of only 32MB of space on a much larger SD card.

There are utilities for accessing Linux file systems in Windows, but I don’t think you really want to do that, as those partitions are not really set up for direct modifications, especially in Windows.

If you want to reformat your SD card with a utility that will “bring back” the appearance of the card’s full capacity, you should use the SD Card Formatter utility provided by the SD Association: https://www.sdcard.org/downloads/formatter/ However, this is not necessary - it’s only to help you verify your card is fine.

This is a screen-cap of my 64 GB SD card after flashing with balenaOS. The G, J, K and N Drives are all Linux partitions that Windows can’t read. Notice the one drive Windows can read is only about 40 MB. That partition has goodies like the RPI’s config.txt, which you can modify as needed, even in Windows.
SD-Partitions

Cheers!
Mark-

3 Likes

this is how it sees it

2020-10-07 21_51_19-_LI

this is the result
it also sees only 30mb

2020-10-07 21_59_37-Messenger _ Facebook

Greetings!

koyaanisqatsi is correct in the sense that “you can’t get there from here!”

Assuming you’re flashing a Raspberry Pi image, (like a version of Raspbian), you will end up with two partitions:

  • A very small FAT32 partition that is read by the device at initial boot, and is later re-mapped to the /boot part of the root file system. It’s usually not any larger than a couple of hundred megs in size.
  • A much larger ext4, (Linux), partition that can grow to occupy the entire rest of the card.

I have not tried flashing a BalinaOS image, but I suspect that it would be something very similar, because the Raspberry Pi’s boot requirements are quite specific, and certain things are expected to be in certain places for the Pi to boot properly.

Jetson Nano images are more complicated. Because they use an interesting variant of the GPT partition structure, (which reminds me more of Apple’s HPFS partition format, or the format used by Solaris/Dec/AT&T Unix), there are at least a half-dozen partitions, each having a particular reason for being there.

(spoiler)
If you can read the one FAT32 partition in Windows, it’s a better than even-money bet that your card is fine and you really don’t need to do anything else, unless you want to re-format the card so that Windows can see the entire capacity of the card again - which makes it unbootable for the Raspbarry Pi.
(/spoiler)

==========================

If you decide you want to “un-flash” the card and use it’s entire capacity for something else, simply re-formatting using the SD formatting tool won’t work - because it is designed to format the first non-Linux partition it finds. To completely re-reformat the device, you have to remove all the pre-existing partitions first, then re-create the device as one single partition that’s the entire size of the device.

To do that, you will need to use either diskpart from the Windows command prompt, or right click on “My PC” (Windows versions before 10), or “This PC” (in Windows 10), and then select “Manage”. You then select “Disk Management” and look for the row that does not contain your “C:” drive.

If your system is a “normal” installation where the primary system hard drive is the standard internal device, your internal drive should be the first row. (My system has both Windows 10 and Linux Mint installed, so there are a lot of extra partitions on that first drive.)

Because this messes with disks and stuff in low-level ways, you’ll need to have Administrator level privileges or an Administrator level password to continue.

For this example, I am going to destroy a freshly-imaged Raspberry Pi SD card and recreate a Windows compatible partition on it. Don’t worry though, once I’m done, all I have to do is crank-up Etcher again and re-flash my Raspberry Pi image! :wink:
 

 
In my case, the SD card is the second row, and you can see three areas: The first (small) FAT32 partition. The second, (larger), Linux partition and - in this case - a bunch of unused space since I reduced the size of the second partition to make the image I’m flashing smaller. The two existing partitions have a dark blue top-bar and the unallocated portion’s top bar is black.
 

 
You click on the second, (Linux), partition and then right-click. In the pop-up you see the option “Delete Volume”. This is what deletes the partition.

WARNING!
Partitions, once deleted, are not recoverable!
(At least, not without fancy tools and a lot of luck.)

Once you select “Delete Volume”, there will be a brief pause and then you will see the “Unallocated” part of that drive becomes larger and only one partition is left - the small FAT32 partition.

You do that again with the remaining partition as shown below.
 

 
Once that is done, the entire device is now “Unallocated”.
 

 
Click into the unallocated space, right click, and select “New Simple Volume” which is Windows-Speak for a “new primary partition”.
 

 
At this point, you can select “New Simple volume” and accept the defaults which will - depending on the size of the card - give you a FAT32, exFAT, or NTFS volume.
 

 
Here you see a newly created FAT32 partition that is now the entire size of the drive.

As a matter of persional opinion, given the choice between an exFAT partition or a NTFS partition on a larger device, I usually pick the NTFS partition unless I have a good reason not to.

2 Likes

The “Formatting failed” dialog is blocking all the important info in that screen cap. But irrespective of that, if SD Formatter can’t format your SD card, the card is likely damaged physically/electrically, or you have some other issue in your computer, like maybe a bad SD card slot. It’s also possible you have other software conflicting with the formatter, such as anti-virus.

Try a new SD card and see if that works better. Don’t buy off-brand SD cards. They are commonly low-performing, high risk of being bad, and can easily be counterfeit. (entirely my own opinion) Get a Sandisk Extreme from a reputable source. Also try formatting the card in another computer, if you can, and see if that works better.

I don’t like disagreeing with other posts on a forum like this, but SD Formatter will most certainly reformat an SD card properly, regardless of what partitions or other data are on it. That’s it’s main purpose, and why the SD Association offers the utility. (and to verify before I posted, I tried it) I use SD Formatter to format all my SD cards, immediately before flashing an image to them, because it clears off any unwanted partitions or other junk data that may get in the way of the flashing/imaging software. To be the most thorough, you need to run an overwrite format rather than a quick format. Also, if the option is available, put a check-mark in “CHS format size adjustment”, to be sure the full capacity of the card is formatted.

The process using Disk Administrator is also a good way of clearing a storage device. It’s just a bit involved if you’re not experienced with storage management.

Mark-

Disk management also sees 30mb, and doesn’t see any other partition

How do you flash the card? Can you please try flashing a balenaOS image with Etcher? You can get one from balena.io/os, just pick the one for your device, though you don’t necessarily have to boot the device with it.

It says: not enough space and cannot be selected

Hi @nmouts,
Can you please also provide a screenshot from your Disk Management window?
@jharris1993 's instructions about deleting all current volumes in the SD card and creating a new one should work and can’t guess the state that you might be in.

Kind regards,
Thodoris

i used balena to write this, as a zip, should i write it as an iso?
https://downloads.raspberrypi.org/raspios_lite_armhf_latest

2020-10-08 21_42_20-This PC

Hi there – thanks for the screenshot. Looking at the options you have selected, it appears you have clicked “Quick format”. @koyaanisqatsi up above says that you need to select “Overwrite format”. Can you try that and let us know how it goes?

If that does not work: can you please try again to burn Raspian to your card using balena Etcher? If that does not work, please post a screenshot of Etcher, and the contents of the Developer Tools window (which you should be able to bring up using Ctrl+Alt+I).

To answer your question about whether you need to burn the image as an ISO: no, it’s perfectly fine to burn Raspian (or any other image) in zip format – Etcher will do the right thing.

All the best,
Hugh

1 Like

it did not word

2020-10-08 23_30_57-Window