Balena Etcher Portable creating unnecessary partitions of usb flash drive

I am new to etcher forums
I am here because of a problem I am facing while flashing my sd card with linux mint 20 cinnamon with the help of balena etcher portable
To be honest everything goes right balana etcher takes it’s complete time to flash my sd card
but after the flashing I noticed an unusual thing that my sd card of about 7 gb is converted into 3.85 mb
I thought the my laptop will not be able to boot by my sd card but it worked perfectly fine without any errors
I just wanted to know why balena created unwanted partitions and how should I fix it without formatting the sd card

Here are the Screenshots

**one storage device converted into 3 partitions **


Hello Ayush, thank you for using our forums!

are you sure that your sd card didn’t have any partition before running Etcher? have in mind that Etcher only copies the image to the SD card, it doesn’t create partitions.

Get here information to restore your SD card and try again

Let us know if that works.

bro my sd card is working completely fine and the partitions were not before there they were created by etcher
please provide any solutions if possible

@ayush222006 the partitions are created by Etcher because they are what exists inside the image you flashed. You can follow the steps in the article Marc linked above to restore the card, this is the solution:

Additionally, we were wondering if you are following some kind of guide to install Linux Mint, and if so, could you share the link here so we may have a chance at understanding how you arrived in this situation?

please chrisys i am just asking the main reason behind this that’s all


@ayush222006 I’m not sure what you’re asking. The reason behind this is that Etcher flashes the partitions that are contained within the Linux Mint image and Windows isn’t able to read them. The blog post link contains all the information you need to know but if you have specific questions we’ll be happy to help more.

thanks brother for your support


It’s quite common for an OS image to only be the size it requires to store the image in a file. That gets written to the SD car as it is, and the OS then resizes the partitions to fill the card when it boots up the first time. This is how it’s done on Raspberry Pi OSes. It’s possible that by booting your laptop from the SD card, that code did not run. But without seeing the info you are referencing to do your installation, we can’t be sure whether that is what’s going on. The screen cap you have provided does not show anything unusual in this respect. It is common for Windows to not be able to read most partitions and for there to be empty space on the SD card immediately after flashing it with a new image.

I’m curious as to why you want to avoid formatting the SD card. I do that every time before I flash a new image, just to make sure the SD card has no issues.

BalenaEtcher does not do anything to the SD card except overwrite it with whatever comes within the image file. If the SD card has other partitions on it before you flash, that usually gets cleared away, and the image replaces all data and partition info on the SD card. It is possible something preexisting on the SD card could trip up balenaEtcher, but those cases are few and far between. Reformatting the SD card with “SD Card Formatter” from the SD Association ( can help you assure the card is completely clear of any existing data or partitions that might get in the way of an image flash.

If you go that route, make sure you select an “Overwrite” format, and if the option is available, check CHS format size adjustment. An overwrite format takes a while to complete, so be prepared for that. Even if you only do a Quick format, SD card formatter will remove existing partitions and data, But it doesn’t write to the entire SD card, and won’t find possible errors on the card.


1 Like

Hey Mark thanks for the reply
and i want to clear that the sd card before flashing was empty there was not a single file in my sd card before flashing and paritions either
but the balenca divides my sd card into diffrent partitions with diffrent size

but hats off to you Mark for such a informative reply

Hi Ayush,

Then what you’re seeing is most likely the result of the image you flashed, and/or whatever automation the image had that manages the storage on the first boot-up.

Just for visual comparison, this is what it looks like for balenaOS. The first pic is a fresh flash on a 64GB card. The second is after the device has booted up, on a 32 GB card. I would expect Mint to do some similar things with storage, because the images are always much smaller than the SD cards.

Point being that I think your card and the data on it are fine, and the partitions will be managed under the hood for you by Mint. If you find that to not be the case when you start using it, let us know and we can help you through some diagnostics.

Before I hit submit on this reply, I flashed my 64GB card with Mint 20 Cinnamon, and it certainly looks odd to me as well. I did this twice - once with balenaEtcher and once with Win32 Disk Imager, and got the same results. I have to admit, it’s pretty disconcerting to see nothing but a 4MB partition from a 1.8 GB ISO image. But they may just have some magic automation going on within Mint that will clear up the odd appearance, or it could be something weird in Windows disk admin.



hey mark hope you are fine
thanks a lot mark you just cleared my issue completely
thanks Ithought that there were problems in my sd card
but because of you I understood that this is the essential process by Linux mint 20 cinnamon

but thanks a lot mark for solving my issue
thanks again brother

1 Like

hey Mark
I have another question will my sd card will be fine if I format it on other operating system
such as Linux or macos will it be again get converted into 7 gb which is it’s exact size

please reply soon

Hi Ayush, your sd card should be fine once you reformat it back to its original partitioining. You may use the instructions in this blog entry to format it using the operating system of your choice:


1 Like

thanks for the answer
and guide

Happy to help, Ayush! Good luck with your project. :slight_smile:

1 Like

I’m having this same issue.

I flashed something once on my USB, and it worked fine. Showed 1 partition.

I tried to re-image the disk with another OS, I deleted partition and reformatted, and Etcher is creating 3 partitions, but not the large file, just a few config files (Minerstat OS). NONE of these files are programmed to talk to the outside world upon boot. My drive shows 2 partitions that are not formatted, and one other one with 19mb (the drive is like 20gb)

This is driving me literally batty.

This is also happening with Nicehash OS.

There is an issue here. I will confirm by using it with a Windows 10 image direct from Microsoft which as we all know doesn’t create multiple partitions.

Edit - ah well win 10 doesn’t work with etcher i’m learning.

Hi Vin,

I tried to re-image the disk with another OS, I deleted partition and reformatted, and Etcher is creating 3 partitions, but not the large file, just a few config files (Minerstat OS). NONE of these files are programmed to talk to the outside world upon boot. My drive shows 2 partitions that are not formatted, and one other one with 19mb (the drive is like 20gb)

Let me see if I can clear up some of the confusion here. Flashing an image with Etcher writes the same partition table and filesystems contained in the source image to the destination disk, but it does not create any partitions itself. Windows does not have drivers to read many Linux filesystems, including ext4, so it reports those partitions as unformatted, even though they do contain valid filesystems. Clearing or rewriting the partition table and filesystems is always possible, even if a particular filesystem isn’t readable from Windows.

Are you having any issues using the drive after writing the images you mentioned?

I did a normal format using disk utility on mac, and also tried disk management utility on windows.

The drive works fine as a thumb drive.

Even if it couldn’t see the files, wouldn’t the info/properties of the drive at least not show all the space is all free on the large partition table of the three that it creates?

Like I said, it worked perfectly fine the very first time I tried it, and I could see the folder at least on my mac of the OS’s files, subsequent attempts (even with the same image that first worked) don’t even show this folder, nevermind work.

Yes, I’m having issues using the drive that’s why I’m posting here? I don’t understand why that is a question.