Etcher failed to finalised after coping a pi-star image

Please excuse this post, I am a complete newbie,

I have tried various microsd card and all fail?

What happens is that it copies the image and then finalises it but comes up with failed and the end, it does not stop at any point in the finalising?

Any help or advice would be greatly appreciated.

Hello! What do you mean by finalising? Maybe you mean validating? Can you share a screenshot with us? Also what version of etcher are you using and on what OS? Finally do you see any errors in etcher’s console?( You can open the console with CTRL - SHIFT - I or cmd + option + I)

Hello, Thanks for your reply, But as stated I have tried numerous time with brand new sandisk 32GB microsd cards! and all of them fail, seem to write ok but everytime it fail on validating?

Windows 10 pro

Etcher v1.5.115

Just tried it again on a 8GB sandisk microsd card and it’s the same, it only copied , please see other photo.

sorry can only post one image, will post the other in a reply.

I do hope that you can offer some help/advice,


The other thing is it creates 3 partitions?
The image is pi-star which is 1.9GB but only copies 60+meg


The boot partition is the only one thats mounted, and it makes sense that it’s small. There will be other partitions that aren’t shown in Windows which will have the root filesystem.

Havng said that, the flashing failed bit is still a concern.

  • looks like you are using the latest version of etcher so thats good.
  • can you check the Console tab in the developer tools window instead of the Elements one? Please share the log that you see there when you flash the device

I have tried various times now, some saying that it’s completed only to find that there is nothing on the sd card also it want to be formatted?, also I have had a look in the developer tools under the console and nothing shows for Balena etcher? How would that show up in chrome?

I don’t understand why it’s failing?

Basically I put a 32 Gb sandisk microsd into the computer and have also tried a card reader as well, open up Etcher then select the pi-star image, then the sd card and then write.

Thanks for all you help

Hi there, can you please try again, this time after failure, make sure Etcher windows is in focus, navigate to the View menu and select Toggle Dev. Tools. There should be some errors displayed on the console tab. If you could share those, that would be great…

Hi, can you tell me what you mean please? Navigate to the view Menu? Is this in google chrome? To check the console?

Hi, we need the information that appears in the console log in the developers tools in the Etcher application. For this we need you to:

  • Open Etcher
  • Press CTRL - SHIFT - I or cmd + option + I to open the developers tools console. Check that the view opened is the “Console” tab.
  • Try to flash your SD card and see if fail
  • Send us the log / screenshot from the console view on the developers tools you opened above

Hope that helps.

gui.js:33148 Verifying 1 device, 95% at 21.90 MB/s (total 21.90 MB/s) eta in 3s with 0 failed devices

gui.js:33148 Verifying 1 device, 97% at 21.80 MB/s (total 21.80 MB/s) eta in 2s with 0 failed devices

gui.js:33148 Verifying 1 device, 98% at 22.10 MB/s (total 22.10 MB/s) eta in 1s with 0 failed devices

gui.js:33148 Verifying 1 device, 100% at 22.50 MB/s (total 22.50 MB/s) eta in 0s with 0 failed devices

gui.js:44749 Finish: 1598029824

gui.js:44749 Terminating IPC server

gui.js:44749 Flash results

  1. {results: {…}, cancelled: false, skip: false}

gui.js:44749 Wed Feb 03 2021 13:00:23 GMT+0000 (Greenwich Mean Time) Done ({“image”:{“size”:1936719872,“name”:“Pi-Star_RPi_V4.1.2_20-May-2020.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:66060288,“type”:12,“index”:1},{“offset”:70254592,“size”:1866465280,“type”:131,“index”:2}],“extension”:“img”,“path”:“C:\important\pi-star\Pi-Star_RPi_V4.1.2_20-May-2020.img”},“drives”:[{“size”:31914983424,“isVirtual”:false,“enumerator”:“SD”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive1",“error”:null,“isReadOnly”:false,“displayName”:“E:\”,“blockSize”:4096,“isSCSI”:true,“isRemovable”:true,“device”:"\\.\PhysicalDrive1",“busVersion”:“0.0”,“isSystem”:false,“busType”:“SD”,“isCard”:true,“isUSB”:false,“devicePath”:null,“mountpoints”:[{“path”:“E:\”}],“description”:“Generic SC32G SD Card”,“isUAS”:false,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“646a09a0-2e0f-45e2-b03c-665a737ceb25”,“status”:“finished”,“flashInstanceUuid”:“646a09a0-2e0f-45e2-b03c-665a737ceb25”,“errors”:,“devices”:{“failed”:0,“successful”:1},“bytesWritten”:1598029824,“sourceMetadata”:{“size”:1936719872,“name”:“Pi-Star_RPi_V4.1.2_20-May-2020.img”,“blocks”:[{“blocks”:[{“offset”:0,“length”:121634816}]},{“blocks”:[{“offset”:204472320,“length”:1357905920}]},{“blocks”:[{“offset”:1563426816,“length”:1048576}]},{“blocks”:[{“offset”:1565523968,“length”:1048576}]},{“blocks”:[{“offset”:1567621120,“length”:1048576}]},{“blocks”:[{“offset”:1569718272,“length”:92274688}]},{“blocks”:[{“offset”:1672478720,“length”:8388608}]},{“blocks”:[{“offset”:1689255936,“length”:8388608}]},{“blocks”:[{“offset”:1706033152,“length”:6291456}]}],“blockmappedSize”:1598029824},“sample”:0.1,“applicationSessionUuid”:“73f6fe2f-75cf-4187-b4fe-0170451a2476”,“flashingWorkflowUuid”:“4dbf65e1-b841-48b7-b42e-10ade7a20c0d”})

gui.js:44749 Wed Feb 03 2021 13:00:25 GMT+0000 (Greenwich Mean Time) SafeWebview loaded ({“event”:{“id”:21,“url”:“",“method”:“GET”,“timestamp”:1612357225243.671,“resourceType”:“mainFrame”,“ip”:“”,“fromCache”:false,“statusLine”:"HTTP/1.1 200”,“statusCode”:200,“responseHeaders”:{“age”:[“81555”],“cache-control”:[“public, max-age=0, must-revalidate”],“content-encoding”:[“br”],“content-length”:[“6095”],“content-type”:[“text/html; charset=UTF-8”],“date”:[“Tue, 02 Feb 2021 14:21:11 GMT”],“etag”:["“c41958e0c3b2707a79fad9ab2a456b21-ssl-df”"],“link”:["</webpack-runtime-c2842b63cff1020331af.js>; rel=preload; as=script, </styles-c4fa86dfd4ad05097eee.js>; rel=preload; as=script, </framework-1412a250c868c0a8c32e.js>; rel=preload; as=script, </50c25a04-b7e01bae03c58615ac93.js>; rel=preload; as=script, </73ad3401-cb39592596eb92d0918d.js>; rel=preload; as=script, </532a2f07-fa5706216a600405b771.js>; rel=preload; as=script, </app-9fcc98a1d48a40ce14ff.js>; rel=preload; as=script, </c943faba-f859f80ceb7f4f7eab31.js>; rel=preload; as=script, </af13d906-36fdbc23fc7dd2f2b2e7.js>; rel=preload; as=script, </ec1189df-f1a321eba12a2bb0c7ab.js>; rel=preload; as=script, </a9a7754c-29508ff4045f1f93a5f6.js>; rel=preload; as=script, </commons-b3fb9651c57d1d917e54.js>; rel=preload; as=script, </component—src-pages-etcher-success-banner-js-fa53b53b6d793d24e65e.js>; rel=preload; as=script, </page-data/app-data.json>; rel=preload; as=fetch; crossorigin, </page-data/etcher/success-banner/page-data.json>; rel=preload; as=fetch; crossorigin"],“referrer-policy”:[“same-origin”],“server”:[“Netlify”],“status”:[“200”],“strict-transport-security”:[“max-age=31536000”],“vary”:[“Accept-Encoding”],“x-content-type-options”:[“nosniff”],“x-frame-options”:[“DENY”],“x-nf-request-id”:[“d24b5ddc-6824-462b-b81c-294800229742-26062388”],“x-xss-protection”:[“1; mode=block”]},“referrer”:"",“error”:“net::OK”},“sample”:0.1,“applicationSessionUuid”:“73f6fe2f-75cf-4187-b4fe-0170451a2476”,“flashingWorkflowUuid”:“4dbf65e1-b841-48b7-b42e-10ade7a20c0d”})

Not sure what is happening in that I copied the console text and replied but just seen a flag Akismet has temporarily hidden your post?

Hi @Wolfbass, seems like the automatic spam filter was too eager to mark your earlier post (with the console logs) as spam. I unmarked it so it shows fine now.

gui.js:33148 Verifying 1 device, 100% at 22.50 MB/s (total 22.50 MB/s) eta in 0s with 0 failed devices
gui.js:44749 Finish: 1598029824

Next, looking at the logs, I don’t see any error. It looks like the flashing completed successfully when you gathered the logs. Have you seen any errors that time?

Finally, once the flashing is done successfully, you should see the contents fine on a Linux machine (like Raspberry Pi) but it’s expected that Windows doesn’t show the contents.

Hi Gelbal, Thanks for your reply, on the text I sent you it shows , fail also what I don’t understand is that windows tells me to format it, So is this because it can’t read it?

I didn’t realise that windows couldn’t see it.?

Sorry the other thing is that it doesn’t see the Micro sd card? would it not recognise the SD card

So have you tried inserting the SD card to the Raspberry Pi and run the device? Does it run fine?

Etcher has this option Auto-unmount on success enabled by default. That’s perhaps what surprised you here. You can turn off this setting if you like. Then if you keep the card mounted, you will not see much on Windows. The default file explorer of Windows is not able to read the content because the flashing prepares the card to be read by a Linux file system.