Balena Etcher DOES NOT Flash OS images to SD cards & USB drives, safely and easily

Using balenaEtcher-Setup-1.5.109 destroyed two new SD mini cards and one original Raspery PI OS card that came with my Rasberry Pi 3B . I am using windows 7 64 bit. It turned each card into unallocated space! This is wrong and bad! It destroyed the info on all cards. It never flashed Ubuntu Mate 18.04 or 21.04 to 64 gig SD cards so that my Ras. Pi would recognize or load the OS. Yes your interface is wonderful and I knowBalena says it is safe, but it is not. I tried to clone my 16 gig raspberry pi SD to a 64 gig SD card and it turned both cards in unallocated space! Windows could not read or format the SD mini cards. You should allow feed back directly to the developers. I am annoyed and angry.

Hey there,
Sorry to hear about this. It might be that the filesystem that was flashed in not supprted on windows and that’s why it would show up like that.

Have you seen our Etcher broke my USB stick … or did it? guide?

Hope this is helpful

Thanks for getting back to me. I was dealing with 2 separate 64 bit SD cards. One for Ubuntu Mate 18. 04 for ARM and one for the Raspberry Pi software.

I spent 3 days trying to get my R-Pi 3+ back to where it was. I was using Ubuntu Mate for Arm 18.04 when I was asked to upgrade to 20.04. I forgot R-Pi suggests you ignore upgrade requests. because they screw things up. So I did and things were really screwed up. So this is what started it.

At first Etcher would not format my 64 gig SD card so it was readable. Etcher formats the card to FAT or EXFAT when R-Pi wants Fat 32 or it will not see the card. Nothing happens.

I found out windows 7 will not format any SD card above 32 gigs to Fat 32. I don’t give up easily, so I kept at it looking for ways to format my 64 gig sd card to format to Fat-32. There are ways. I wildly tried everything and lost track of what I did.

Then Windows 7 was suddenly able format my 64 bit sd card to Fat 32. It is one of those anomalies I can not explain. Suddenly the choice for FAT 32 was there when it was not in the beginning. Then Etcher worked with Ubuntu Mate 18.04. My R-Pi would not accept 20.04 flashed by Etcher. I tried MANY times!

For the Raspberry software I lost when I was trying to clone the original R-Pi sd card the unit came with using Etcher. This is when both cards became unallocated space. I used the windows 7 system tools to make both SD cards into new volumes.

I went to the R.Pi website and downloaded Noob. and extracted it directly on to the 64 gig Sd card so I reclaimed what I lost and all is well. To make a back up SD card for the R-Pi software, I used the resident clone software on the R-Pi and there were no problems.

I am a tiny bit above a normal end user so if the following suggestion sounds crazy you will understand. Etcher needs to be able to format to FAT 32 when the SD card is larger than 32 gigs when flashing a card for an R. Pi/ARM.

Thanks for getting back to me so I can make this suggestion.


This is likely a reflection of the fact that FAT32 filesystems are limited in their partition size to 32GB, thus formatting a single drive larger than that to one FAT32 fs is undefined. Did the windows 7 formatter perhaps format only the first 32GB of the card?


I did not look. I was pretty exhausted after wrestling with this problem for 3 days. This is possible. If it was done like you imagine, there was no explanation or permission asked. But the choice for FAT32 was not coming up in the beginning. I had no idea about this limitation regarding SD cards above 32 gigs going in. I found out about it by reading around. I found a program called Easy Partition Tool that said is could do the formatting I needed. It was a trial, but it was one of those that got you to the point of doing the formatting you needed done, but stopped dead until you gave them some money. I was not giving them my money under those conditions.

It was after I had loaded Easy Partition Tool on my hard drive that Windows 7 finally started giving me the option for Fat32. I later uninstalled Easy Partition Tool. I really have no idea if the program rearranged something in Windows 7 or not. It is late where I am now. I only use the R-Pi computer occasionally. I just wanted to explore the world of single board computers. The price was right. The next time I get a chance I will check the SD card. With larger SD cards being so cheap now, the 32 gig limitation must be worked around by developers. I am sure most people don’t know about it.