Win 10 - User did not grant permission

Here’s a bit of a weird one. Was using Etcher v1.5.109 and wrote a couple RPi images to an SD card. In the same sitting went to write another one and got a “User did not grant permission” error.

The weird thing is it worked fine for those first couple images and then it stopped. I think Win10 did something mysterious.

I’ve tried a few different things to try and get it working again and nothing seems to work. I’ve tried:

  • Running as administrator
  • Lowering UAC
  • Disabling Controlled folder access
  • Turning off virus protections
  • Using the portable Etcher version
  • Upgrading to v1.5.110

None of these do anything different. I’m sure it is some Windows thing, but I’ve tried every suggested option and nothing works.

Hi Ray,
just to give us a little more info could you post the contents of the console developer console when the error has occurred. You can get to the console by pressing ctrl shift + i in the etcher window.

Sure. Here is what I get:

Rather than disabling controlled folder access, perhaps try whitelisting C:\Users and sub-folders? Presumably you are also right-click-run-as-administrator…

Running as Admin makes no difference. I didn’t have controlled folder access turned on to begin with. Should I turn it on and then do the white listing?

It’s worth a try, we’ve had users report success with the whitelisting method…

Had the same issue today. The whitelist worked for me when running as admin.
Did have to close it all up and re-run as admin after adding the whitelisting. Didn’t work while original exe was still open.

I have the same issue.
Can you please elaborete a little on whitelisting? Is it whitelisting from virusscenner / windows defender? I have Norton installed, (temp.) disabling this does not do the job.

Hi @Ard,

The suggestion was to whitelist controlled folder access.
Let me point you to a guide on how to achieve that:

On top of that I would suggest to also try keeping Norton disabled while giving this a try.
Let us know whether that fixes the issue for you.
Kind regards,

facing the same issue. Unable to flash drive. Says user did not grant permission. How to resolve this?

I’ve just downloaded it today and I am getting the same message. I’m running Windows 10 Home version 1909

I had the same issue and did the following after installation:

  1. Reboot
  2. Right click and select “Run as Administrator”
  3. Start flashing!

Now it starts flashing… but blanks out the application after 34 pct and… kind of freezes.
I have previously used Raspberry Pi Imager… I will revert to that as quality of BalenaEtcher is low

Thank you, the Raspberry Pi Imager worked for me.

Had same problem. Ran as administrator and seemed to work but then it said to put a flash drive in G: which had a new blank 32 gig drive the light was flashing of the F: drive which was the source drive for using balenaEtcer as a program to clone a drive. Windows 10 is my operating system and it may not like belanaEtcher as my original flash drive is no longer usable says I need to format it to use Any thoughts?

Hey all, have you tried Whitelisting like it is mentioned earlier on this thread?
If you want to check the console to see if there is any other Errors Press Ctrl+Shift+I

Hey Nathan, regarding your unsuable drive, that happens because Windows uses another formatting type, please check this out to be able to re use it on a Windows file system:

I tried the whitelisting and it did not make a difference.

@hernan43 can you try the latest version of etcher? v1.5.111

That test was with the most recent version of etcher. I downloaded it yesterday and reinstalled to test it out.

Hi @hernan43

Thank you for reporting this.
I can’t reproduce it locally.
Can you please double check you use 1.5.111 ? (You can see the version number in the settings). Especially on Windows as 1.5.106 - 1.5.110 has a severe bug in the clone drive feature.

The message you see comes from sudo-prompt

Can you check that elevating commands works on your Windows ?
Open a cmd and type powershell.exe Start-Process -FilePath calc.exe -WindowStyle hidden -Verb runAs
This should ask for your password and run a calculator as administrator. That’s what sudo-prompt does, exept that it doesn’t run a calculator but the command you ask it to elevate.

Verified 1.5.111

When I run the above command I get:

‘powershell.exe’ is not recognized as an internal or external command,
operable program or batch file.


I installed Windows Terminal some time ago and it prompted me to “try” the new Powershell beta which I believe I am using. I’m wondering if it doesn’t like that.