balenaetcher not working for windows

balenaetcher{stack:Error: User did not grant permission message:User did not grant permission.
Windows 10
balenaetcher 1.5.104
how to resolve?

Hi, looks like your user does not have the necessary permissions to write to the disk/card you’re trying to flash. Can you run etcher as administrator?

2 Likes

hi, i face the same problem here, and i tried to run etcher as administrator but still get the Error: User did not grant permission message.
still don’t know how to resolve this problem.

by the way this is the error picture i capture from the developer tool.

hey there,

Can you please confirm the following:

  1. which balenaEtcher version are you using?
  2. When you attempt to flash an image, do you see a prompt from Windows asking you to allow etcher to make changes?

Thanks

Something changed between 1.5.109 and 1.5.104. 1.5.104 would elevate and prompt via UAC when I started the flash. 1.5.109 does not and gives this error.

A workaround is to run 1.5.109 as administrator.

Hi there, I’ve just deployed a fresh Windows 10 x64, installed Etcher 1.5.109 and flashed an image to USB. I started Etcher normally and got an elevation prompt after hitting the flash button.

Are you able to default all UAC settings and try again please?

I’m having this problem also and I’ve change the UAC to the bare minimum and still get the user permission error.

edit: fixed it! It seems that controlled folder access was turned on and blocking the app, I just added the balena app to the whitelist and it worked

Hi,

I just installed etcher 1.5.110 on Windows 10 Home, and I am receiving the same error. Windows does not prompt to allow etcher to make changes.

I confirmed that UAC settings are at default and that controlled folder access is turned off, and that the target drive (uSD card) is not write protected.

It appears to work now, after setting the shortcut to etcher in Windows Start menu to run etcher as administrator.

1 Like

Thank you.
Running etcher as administrator worked for me.

Thanks! I was having trouble trying to flash Kali Linux 2020.3 on my USB Drive. You Fixed It!

Thanks a lot!! I used Etcher as Admin on Windows 10 and it worked!