Wifi not connecting Pi Zero W


Dear Hugh - the country did the trick!!
I’m in Australia for info - which AFAIK uses all bands 1 to 13 but excludes 14.

THX a lot !

That’s great to hear!

So now I can use the dashboard :slightly_smiling_face:
But still not working.

Best I have seen is Spotify and Bluetooth actually visible and connecting (although rarely - and not stable) - but with no sound at all :frowning

FYI https://paste.ubuntu.com/p/RMFt3STQ3B/
and https://i.imgur.com/5NsS3KW.png
and https://i.imgur.com/LjegSUX.png
(I’m using a Adafruit I2S DAC)


Have you checked our troubleshooting guide for balena Sound?
See - https://sound.balenalabs.io/docs/support#troubleshooting

Let us know what you have tried from there and the results, so that we can be in a better position to help

There is nothing in the troubleshooting guide that applies here.

The device is visible in Spotify connect - but as soon as I choose it, it disappears.
Lots of things going on in the log (posted above)

Hey can you download the full logs and send those instead? I’ll also ping the balenaSound maintainer to have a look if it is a balenaSound issue or something else maybe.

Also, can you check if you credentials are correct, maybe it’s related to https://github.com/balenalabs/balena-sound/issues/131?

Thx Stradevski
Is there a CLI comand I could use to check my credentials? That;s what the OP mentioned in the post you linked - but I can;t find out what comand he used

I think the user refers to https://github.com/librespot-org/librespot. Maybe you can try one of the options mentioned in the issue and see if any of the fix the issue for you. Do let us know if you manage to get it working.


Also, how do I get the full log? I’d prefer not having to turn off the pi and get the card out now that I can terminal in!

In the logging terminal in the dashboard there is a download icon, you can just click that.

That’s what I have done for the last one but it obviously includes only the last “n” rows :frowning:

Usually that should suffice, but you can also SSH into the device and run journalctl --no-pager to spit out all the logs and copy them, for example.

Log (journalctl) after it had been running for a while:

Doing one now of a fresh start

Newer boot

FYI, I was trying to test the audio using the instructions from Chrisys in balenaSound - sound not working on Raspberry Pi 2 out of 3.5mm jack using Spotify - but I cannot ssh into the spotify container although the service is running

Lots of things not working somehow.
One element of the dashboard says Spotify is running, the other says it has exited

The “Device diagnostics” points in the same direction

Hi Pierre, based on the logs and errors you shared this doesn’t seem to be a problem with balenaSound but rather balenaOS. Logs show the supervisor erroring out often, moreso the fact that the Upnpn and bluetooth-audio services are not running is another indicator that something is wrong at the OS level.

I’d like to ask you a few questions:

  • Just to clarify, this is running on a Raspberry Pi Zero W, correct?
  • What version of balenaOS and supervisor are you on? (Check dashboard for this info)
  • Can you extract logs one more time but with this command journalctl -a --no-pager?

I also noticed that you are running balenaSound 2.x version. We just released version 3 with a bunch of improvements, and going forward in general will be easier to focus on the latest version for troubleshooting. If you can update to the latest version that would help.