Unable to connect to WiFi on RPi Zero W

Hi,

I am having trouble connecting my raspberry Pi zero W to the application. I keep getting:

IPV6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
brcmfmac: power management disabled

If I use the same SD card on a raspberry Pi 1 and connect via ethernet, it works fine.
I am using balenaOS 2.32.0+rev1

Is it related to the issue: https://github.com/balena-os/balena-raspberrypi/issues/330 ?
Or am I configuring something wrong?
Thanks

Hi there,

Have you tried mounting the SD card on another computer and confirming the wifi credentials are accurate? We have some tips for checking that available here. I am checking on the progress of that ticket as well, but it’s best to double-check the credentials first.

Hi @xginn8,

Yes, indeed I have checked the wifi credentials and they are fine. I still cannot connect.

Grateful if you could help,

Thanks
Rahul

Hi again,

Is the network you are trying to connect to 2.4GHz? The Raspberry Pi Zero W can only connect to networks operating at that frequency. Additionally, if you test the Raspberry Pi 1 does it come online properly via wifi (using the same SD card/wifi network)?

Please let us know!

Hello,

Thanks for getting back promptly. Yes I have a 2.4GHz router. I cannot test using the Raspberry Pi 1 since I only use the ethernet port on it :frowning:

The Raspberry Pi Zero W works fine with another SD card running raspbian.

Hey there,

I just created an application for rpi3 and tested. The device connects directly without any problem. I am having the issue only on rpi Zero W.

Thanks

Hey @rahul, that sounds very strange indeed. Sorry for asking so many things to try (that’s just remote hardware debugging), but could you try these:

  • If you have the image that you used with the Pi 3, mount the SD card, and copy out resin-boot/system-connections/resin-wifi-01 (I think that should be the filename, or sometimes just resin-wifi in the same folder) which has your wifi setup in there. Then flash a card with with the Pi ZeroW’s balenaOS image, and copy this file in to the same place (in effect, testing the known working wifi config in the image that had network issues
  • You mention that you see IPV6: ADDRCONF(NETDEV_UP): wlan0: link is not ready, how do you see that? You connect into the device with the debug console? If you do, can you also show the output of nmcli c (the connections reported by network manager), and maybe the NetworkManager logs with journalctl -a -u NetworkManager --no-pager that might show any issues.
  • Could you also take a picture of the bottom side of your Pi ZeroW, where the part number and other information are, and post it here? So that we can know exactly which revision you are having problem with.

I’ve just tested a Pi Zero W V1.1 with balenaOS 2.32.0+rev1 in our office, and that connects, so looking for any piece of extra information that might explain what’s going on here.

Also, just to note, as you originally asked about https://github.com/balena-os/balena-raspberrypi/issues/330, it is not relevant for the Raspberry Pi Zero W, only to wifi chip present on the balenaFin.

Hey @imrehg,

Thanks for the detailed explanation. I have the same revision as yours. I noticed the link was down recently even using Raspbian, so I will check if it is not a hardware issue or something else.

As for the output, I connected the RPi Zero W to a monitor.

I will check the recommended solutions and get back to you.
Thanks

Hey @imrehg! Sorry for the delayed response. I needed to borrow the rpi3 to test again(it was not mine).

So after some tests, it seems like the wifi chip on my rpi zero W is damaged :frowning:

Hi, can you please tell us how did you come to conclusion that wifi chip is damaged? Thanks

So the wifi was working intermittently before. Now the interface doesn’t even show up.
I tried with raspbian also, the wifi interface cannot be found.

Thanks for the clarification – mystery is solved. Then sorry to hear that the wifi module is damaged.