User did not grant permission when trying to mount a raw image

So I’m trying to mount my raw image to my Pendrive and gives me the error of “User did not grant permission”.

I tried all type of things:
-Running as an administrator
-Checking if I have enabled the Controlled Folder Access
-Formating Pendrive
-Putting items in to my Path environment variable,


And after trying all answers in google and still no clue what it is.


Hi, there have been a couple reports of a similar issue but unfortunately we don’t have a fix for this at the moment. Could you please check the etcher DevTools when you see this error and paste them here in case there is any useful information in diagnosing and debugging this issue?

Are you seeing this issue on a non-Windows machine as well? If so, I see in some internal notes that we have seen success in working around this issue in the past (albeit this shouldn’t be necessary in the first place) by running the following from the command line: sudo /opt/balenaEtcher/balena-etcher-electron %U

Elevating command: C:\Users\angel\AppData\Local\Programs\balena-etcher\balenaEtcher.exe C:\Users\angel\AppData\Local\Programs\balena-etcher\resources\app\generated\child-writer.js
gui.js:37 Terminating IPC server
gui.js:37 Flash results {}
gui.js:37 Error: User did not grant permission.
at gui.js:37:773107
at ChildProcess.exithandler (node:child_process:415:5)
at ChildProcess.emit (node:events:526:28)
at maybeClose (node:internal/child_process:1092:16)
at ChildProcess._handle.onexit (node:internal/child_process:302:5)
(anonymous) @ gui.js:37
logException @ gui.js:37
flashImageToDrive @ gui.js:341
await in flashImageToDrive (async)
tryFlash @ gui.js:341
callback @ gui.js:341
(anonymous) @ gui.js:37
ca @ gui.js:35
ja @ gui.js:35
ka @ gui.js:35
wa @ gui.js:35
Aa @ gui.js:35
ya @ gui.js:35
Da @ gui.js:35
Ad @ gui.js:35
Gi @ gui.js:35
Kb @ gui.js:35
Dd @ gui.js:35
(anonymous) @ gui.js:35
exports.unstable_runWithPriority @ gui.js:35
Ii @ gui.js:35
Cd @ gui.js:35
sentryWrapped @ gui.js:37
gui.js:37 Error: Error invoking remote method ‘enable-screensaver’: No handler registered for ‘enable-screensaver’
at o.invoke (node:electron/js2c/renderer_init:57:526)
(anonymous) @ gui.js:37
logException @ gui.js:37
(anonymous) @ gui.js:354
gui.js:35 0 devices, 0% at 0.00 MB/s (total 0.00 MB/s) with 0 failed devices

Thank you for pasting the content from the DevTools, I will ask an Etcher dev to review it, we’ll let you know if we come to any conclusions

when your trying to mount a raw image in virtual machine or operating system , you may encounter an error msg which say "user did not grant permission" or something similarity. this error msg typically indicate that user account you are using does not have sufficient permission.

I’m an administrator.

Have you tried changing the ownership of the file or folder that contains the raw image? You can try to take ownership of the file or folder by right-clicking it, selecting Properties, going to the Security tab, and clicking Advanced. From there, you can click on the Owner tab and change the owner to your user account. This may allow you to gain permission to mount the raw image to your pendrive.

Im the owner of the PC. all will be in admin.