Etcher v1.5.39 AppImage Elevation Cancelled

I can’t get Etcher to flash anything, the developer console says the following:

error Error: User did not grant permission.
at /tmp/.mount_balenarwWRLB/resources/app.asar/node_modules/sudo-prompt/index.js:111
at ChildProcess.exithandler (child_process.js:310)
at ChildProcess.emit (events.js:182)
at maybeClose (internal/child_process.js:961)
at (internal/child_process.js:380)
at Socket.emit (events.js:182)
at Pipe._handle.close [as _onclose] (net.js:596)

Of course I entered the password correctly.

Any idea how to fix it?

@Bobson welcome to the forums!

Could you let us know what OS and what version of Etcher you’re running?

Linux Mint 19.1 and Etcher v1.5.39.

@Bobson thanks for that. I’ve pinged the Etcher team to take a look at the issue. Out of interest what’s the username on your machine that you’re providing to the elevation prompt; do you have any special characters?


This is strange, as a workaround you may try to run etcher as root directly: sudo balena-etcher-electron.

@chrisys The username is nothing special just bobson.

@zvin I Tried sudo balena-etcher-electron in the terminal, says sudo: balena-etcher-electron: command not found.

Does it matter that it’s the AppImage version?

Try sudo balenaEtcher-1.5.39-x64.AppImage in the folder where you dowloaded the AppImage then.

Finally got it fixed.

AppImageLanucher was what was causing the problem after all, once I uninstalled it Etcher worked fine.

@zvin sudo balenaEtcher-1.5.39-x64.AppImage didn’t work, but sudo ./balenaEtcher-1.5.39-x64.AppImage in the folder with the AppImage does.

Thanks for everyone’s help with this.

Great, thanks for the update!