USB not formatable after use with balenaetcher

(Windows 10) USB not formatable after use with balenaetcher. Repeated with 3 (out of 3) USB drives (2 of which were new). Other USB drives work fine when not used with balenaetcher.
Diskpart clean doesn’t work.
chkdsk comes up with no errors.
does not format with disk management.
does not format from cmd. (with both fat32 and ntfs, as well as quick on/off)
sfc /scannow comes up with no errors.
write protection is disabled.
making volume active yields no results.
volume has been deleted and recreated.
file explorer>properties>tools>error checking>cannot access disk
driver updated

cmd detail disk results:

Philips USB Flash Drive USB Device
Disk ID: FEBE362F
Type : USB
Status : Online
Path : 0
Target : 0
LUN ID : 0
Location Path : UNAVAILABLE
Current Read-only State : No
Read-only : No
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
Clustered Disk : No

Hello @potatoes welcome to the balena community and apologizes for the experience.

Did you try to follow the steps that we provide here? Etcher broke my USB stick … or did it?

Let us know if this helps!

yes I have. clean command could not access the usb

You need to run the command with admin access. Try the following:

  • Windows+X and make sure to open powershell(admin) and not just normal pwershell

Let us know if you any follow-up questions.

I tried this and it got worse. The disk was still “write protected” and the second time I tried your process, i got this:
Disk 1 is now the selected disk.

DISKPART> create partition primary

Virtual Disk Service error:
There is not enough usable space for this operation.

And that’s it–no other options. Any ideas?