Corrupt USB drive from balenaEtcher

I used balenaEtcher to flash ubuntu-22.04.3-live-server-amd64.iso into a cleanly formatted USB drive.

The process ended with an error flashing the device. Now it’s unusable and unformattable (write protected) but still recognized as a drive by Windows 11.

I tried following this guide Etcher broke my USB stick … or did it?
But the clean command on diskpart gives an I/O device error.

Hi @capofantasma97,

Thanks for reaching out. :slight_smile:

Flash drives can suddenly fail for a lot of reasons, so I’m not exactly certain of the cause, but I found an article that I would use if I were in the same situation to see if I could bring it back to life: Fixed: Diskpart Clean Errors in Windows 11, 10, 8, 7

Sending good vibes to you that the USB drive is repairable! Let me know if this does help… I always like to keep good tips around in case someone else needs the same help.

That guide suggested among other things to run attribute disk clear readonly on the problematic drive in diskpart. That solved the issue, as I was then able to clean, create a new partition and format it.

It works correctly now.

Glad to hear it, thank you for confirming that the guide was helpful and resolved your issue :slight_smile: