Used etcher in win10, now flash drive isn't readable

I started the process of putting Linux mint onto a flash drive to install on my laptop. I had JUST sampled fedora with the same installation of etcher on the same usb flash drive with zero issues.

when I started writing mint to the drive, etcher threw an error saying it was taking too long to start, and had therefore cancelled the process. after that, windows cannot read the disk, nor format it. it knows a usb flash drive is plugged in, as usual, it just can’t interact with it.

I’ve tried a few solutions on the internet, most of which are pretty generic. unplug, replug. uninstall, reinstall driver. disable indexing. disable fast boot, etc. etc. nothing effects this issue.

I don’t have access to another machine on which to test the drive.

please help. I cant do my homework efficiently in windows as it’s quite slow to load everything. including itself.

Sorry to hear about this issue. It is usually a matter of Windows getting confused about Linux partition tables, or otherwise unfamiliar data written to certain areas of the flash drive. The suggestions in the following guide (section Recovering broken drives) are able to recover the vast majority of such issues. Let us know how they work for you.

I ended up downloading Rufus. Rufus was able to see the drive and manipulate it with ease. It didn’t seem to care about whatever issue Etcher and Windows were whining about.

Lesson learned. Don’t use Etcher.

1 Like

Same thing here but somehow different.

I downloaded a Mac OS image from windows and tried to make a bootable USB drive with MAC OS in order to make a Hackintosh. I did it about 6 months ago with no issues.

Now Etcher made my USB drive unusable. It could not be read anywere, not even in BIOS. So i trow it away. It was an error while flashing the drive to the point it cannot be used ever.
I dont know why Etcher changed the name to BalenaEtcher, wtf is this? And why all of the sudden, Etcher is so garbage tool? Ill try again, i bought a USB thumb drive again today, and ill try again, and i will record every second of the process. If Balena fucking Etcher will broke this USB thumb drive also, im gonna ask them a refund for the money that i spend on that USB thumb drive.

Hi, I would suggest to first trying the comment from Paulo on recovering a broken drive and see if that works for you. Etcher is an open-source and free tool and we put in a lot of effort to make it as stable and reliable as possible. There are numerous successful flashes happening every day, and one specific use case not working doesn’t make it a “garbage tool”. I would also suggest, if you are not happy with Etcher, to try out other alternatives, such as the one Rufus as mentioned above.

My system stayed on the same version of Balena 1.5.52, and started having this problem after a features update to Windows10, version 1903 was installed on August 19, 2019. After allowing the access in the Windows 10 dialog after clicking Flash, Etcher reports the error seen in the first entry here: Etcher 1.5.5 windows, writer process problem

After that, a Microsoft notification appears that an attempt to change was blocked. The Protection history gets an entry which says Protected folder: \Deivce\Harddisk3\DR5, Blocked by: Controlled folder access.

Obviously, the only listed folders to be protected are C:\Users{user}… Documents, Music, etc, etc. Something in the update is clearly blocking more than they say. This update has added the phrase “ransomware protection” to their changes, so I suspect they are being very aggressive in what they block until people complain enough.

I’m not sure what you can do about this on your software, but I have a solution I may go to very soon: dump Windows. Microsoft is acting like a bully. This last update removed shortcuts I use on startup, and they had no notice they would do it, and no log of what they did remove. That is HIGHLY unprofessional.

Hi @rambotech .
We’ve had another report of Windows Defender Ransomware Protection blocking Etcher here The writer process ended unexpectedly. 1.5.51 .
It seems like disabling it makes things work again.

That confirms what I found, as far as versions. I installed 1.5.54 (since 1.5.55 was released on Aug 19, the same day as the Windows update) to ensure it was Windows. The same error appeared on it as well. I just disabled the Controlled folder access in Ransomware protection, and it is working fine again.

Thanks, zvin, for the quick response.