USB flash drive damaged after using Etcher

support

#1

On the recommendation of Linux Mint, I tried using Etcher to make a USB bootable. But, the unit was damaged.

To recover the USB, I used the Windows 10 Disk Manager. I selected the damaged drive, then “New Simple Volume”. I followed the steps of the wizard by selecting partition size, disk letter assignment and formatting (I chose FAT32).

That way I recovered my USB drive.

I read this same error in several posts in this forum, and no one from Balena responded by giving any solution.

I will definitely not use Etcher again.

It’s safer Rufus.


#2

That’s because there’s no solution - Etcher doesn’t “damage” nor break nor corrupt sdcards, it’s usually just that some users don’t understand that flashing an OS on a usb/sdcard/… makes it usually (and I’d also say obviously) not readable by the OS you’re working on, but you will still see it with other reading tools.
I suggest reading through our User Documentation in case your situation listed there.
I’d also like to know what you mean by “damaged” and I understand your frustration, but with some patience we can figure this out. Otherwise, we’ll still be here to help if needed!