Upgrade from v1 to v2 failed

Howdy, could you please take a look at the reason device apps/273905/devices/594068 failed during Resin OS upgrade?


Checking it out, can you enable support access?

Also, should we finish up the update for you on this device?

Done. You can finish the upgrade.

1 Like

Hey. So finished the update. It looks like the update hit a rare race condition in a bad way, just digging into that and making sure that it does not happen again.

When finishing up the update manually, unfortunately I’ve missed one step, and that means that your application’s /data content wasn’t backed up and restored over the update. Really sorry about this, taking it very seriously and checking how to prevent such things in the future…:frowning:

That’s awesome that you were able to kick it to the new version. Don’t worry about /data, it’s all transient.

Thank you!

Phew, lucky this time. Much appreciated for the feedback, and let us know if there’s any other issue with the device!
Just working now to fix both things mentioned.

Have you updated any other device yet, that went through fine, or was this the first one you tried?

This is the first and only v1 to v2 I’ve tried. I’ve taken one from v2 to v2 without any issues.

Makes sense, thanks! I wonder if you have many 1.x devices left in your fleet?

There are a few /apps/273905/devices. Happy to try an upgrade them to help you test out the changes…

That’s a very kind offer, thanks! Will keep you posted!

Hello again, if you have time, here is another v1 -> v2 that’s gone funny.

(PM sent)


Thanks, checking it out!

Fixed up, the device is now running the updated resinOS.
This is an issue that we see rarely and looking for ways to reproduce, thanks for the heads up.

Thank you!

1 Like

@imrehg hello again, I found another device that finally popped back online on v1 (5a2b5498dd6010f46f8b84ddeedeed827fc1103ef33809e5354b5fb7f3a392) any chance to get this upgraded to v2? The automatic upgrade failed…

Hey @ab1, that looks like our good friend of btrfs again. Fortunately it was pretty straightforward to straighten it out - rebooted the device and retried the update from the dashboard. Now it is running 2.3.0+rev1 properly, and you can continue update it to the 2.x version that you wanted to get to.

Thanks for the heads up! :slight_smile:

Thanks again!

1 Like