ResinOS host update from 2.0 to 2.3 is failing on Raspberry Pi 3

The device apps/741315/devices/828373 fails to update its ResinOS version.

I have granted support access, feel free to do anything to it (bricking/data loss is ok).

The device is specially set up for you guys to debug, I will wipe it when this issue is resolved.

Thanks for the great platform

  • Adrian

Hi, checking it out.

Hi Adrian, we’ve checked out the device, and seen that there were multiple attempts to update. All of them seem to have been interrupted while the device was still downloading the OS update. So everything was working well, but depending on your network and SD card speed, that step (downloading and extracting the image) can take some time. Just re-run the update now from the dashboard the same way as you were doing it, and the device updated without a hitch (now running 2.3.0+rev1)

Can you tell us what was the failing in the first place? It was just taking a long time, or anything didn’t work? We are working on making the update process more informative, and this feedback is very helpful.

Thanks a lot, and glad you have a good time on resin! :tada:

Hi @imrehg,

In the last update attempt, I did not tamper the device but I checked the dashboard logs about 30 minutes into the update process and noticed the update silently failed and the old version is running, I created this thread and left the device overnight unattended.
I am noticing the device is now running 2.3 (probably you guys did it).

If it helps I can wipe the device, install 2.0 on it again and share it with support.

PS: This is unrelated, but can the supervisor be updated independently from ResonOS using the dashboard?

I see, thanks for the heads up. Have some ideas to test. By any chance, have you tried to update the device quite soon after booting it up?

Yes, updated the device from the dashboard as mentioned above to see whether there was any issue, as the device seemed fine.

Thanks for the offer to retry. If you’d like, you can wipe and try the install again from the dashboard, I think that’s a good re-check.

Currently the supervisor is updated by either the host OS update, or by the support agents. Supervisor updates are also something that we are working on improving. Any particular thing you have in mind?

I did try to update the device as soon as it was booted up. I did a few retries and I had no more issues.
Thanks for the help!

Hi, thanks for the feedback, and glad it worked!
We’ll still keep looking into your original issue, to make sure it does not happen. Cheers!