Unable to use Etcher with Win11

Hello. I have been able to use balena Etcher without problems with win10. Now that I upgrade to Windows 11, I can’t anymore.

As soon as I want to flash a usb stick, I got a win 11 error that says: Drive D: not found, that message apears about 5 times and then etcher shows: Something went wrong flasing you usb.

So far I have tried 3 isos: Zorin, Ubuntu and Kali linux. The final result of this is that the usb sticks became unusable, not even the balena instruccions for windows allowed me to fix those usb sticks and I end up throwing them out.

I just download the new portable version for etcher: 1.5.122 and tried again, but always the same thing happens: Windows says drive D can’t be found, even I use Etcher with admin priviledges.

Am I missing something?

Hello, Sorry to hear you are having problems with etcher on Windows 11. We haven’t encountered this problem before, and would like to know more about your specific OS version. Would you mind posting here the “Windows Specifications” section you see when you go to Settttings -> System -> About? Thank you.

Hello. I was thinking could be a problem with security or priviledges, but still happens when I used it as Admin.

Here is the Win Specs screen. It is in spanish, but if you have some problems with the translation, let me know:

Thank you for your help


Actually, always recieved 5 error messages of directory not valid and then both Etcher and Win send me error messages:

Thanks again.

Windows 11 was not working for me either. I did two things to get it working again.

  1. Turned off “controlled folder access”. You can find this in your windows settings. If you are using a domain managed computer, you will have to turn it off via your local group policy. This got me to the point where Etcher was stuck on the starting screen.
  2. Turn off windows defender real time protection.

Thanks 307IT, your suggestion worked like a charm!

Actually, since I couldn’t find the controlled folder access I just disable windows defender real time protection and worked excellent that way.

So it is clear to me, that for Windows 11, Etcher is a virus and balena engineers hadn’t even try to fix this.

Thanks again.


You don’t even have to do that. It tells you which folders are protected (against ransomeware and other malware). Just move the file you want to use to a non protected folder. If you want something more universal, assign rights to the etcher programme.