File not loading in balenaEtcher version 1.19.19

Hi,I am using Windows 11 and want to install Batocera on my 14GB flash drive but have an issue in Etcher and need help.

When I click the file it doesn’t load or let me select my drive.I don’t know what to do at this point.


I have the same issue here (i also have windows 11 and i tried doing it on my win10 laptop and i sill had he same issue)

1 Like

I have the same problem, once I select the image it doesn’t let me select target. I’m using Windows 10 and it refuses to work. Was having the same problem in Mac earlier, tried on Mac again and it accepts image but doesn’t detect device to flash.

Was having the same issue. Just searched for an older version on google and that worked for me. I installed the Aug 2023 version and didnt hang anymore

1 Like

thanks this fixed my problem. that new update is crap


File not loading in balenaEtcher version 1.19.19 give me a short answer for this forum question


Try the following steps:

  1. Check the File Format: Ensure the file is a supported format (e.g., .img, .iso, .zip).
  2. Run as Administrator: Open balenaEtcher with administrative privileges.
  3. Update balenaEtcher: Ensure you have the latest version installed.
  4. Verify the File: Make sure the file isn’t corrupted by verifying its checksum.
  5. Re-download the File: If the file is corrupted, download it again from a reliable source.
  6. Try a Different USB Drive: Sometimes the issue could be with the USB drive itself.

If these steps don’t help, provide more details about the error you’re encountering.