Unable to flash/boot in new Intel NUC (NUC10i5FNH)

Hello everyone, I seem to be having the same exact same issue as this thread, except I’ve booted it with an USB drive and the problem remains.

I have the same exact kit but i5 instead of i7, NUC10i5FNH, with a Intel Core i5-10210U.

More info, we are currently using openBalena to manage a fleet of devices at my work. Because of documented compatibility issues with recent supervisor versions, we are using balenaOS 2.47.1, but the problem remains with balenaCloud and latest version (2.50.1+rev1). I’m unable to provide any logs because the boot process simply won’t even start, all I get is a white cursor stuck on what would appear to be grub’s startup process, before showing boot options.

Furthermore, the same exact USB stick flashes and boots just fine on older NUCs, namely NUC7i5BNH and others.

As per suggestion on another thread, I’ve tried to disable all other devices in order to avoid any boot order issues, but nothing changed.

It must be some kind of hardware compatibility issue!?

Thanks in advance.

Turns out it was related to this issue: https://github.com/balena-os/balena-intel/issues/283 and this https://community.intel.com/t5/Intel-NUCs/NUC10-can-t-enable-Legacy-Boot/td-p/602288

For some reason, I need to disable modern standby (didn’t even need to turn on Legacy Boot) in order for the flash drive to work.

New issue, it seems as though network doesn’t work…

Hi @citizenjc,
I’m glad that you found our balena-intel repository and managed to provision and get you NUC to run balenaOS.
Now about the networking issue that you mentioned, in the issue that you linked above there is also a comment from one of our engineers that in order to get the WiFi to work you will need to be running at least balenaOS v2.50.0.
It seems that that Ethernet is still not supported though, but will be once balenaOS upgrades to kernel v5.5 so that it has the required drivers for the newer NUCs
See: https://github.com/balena-os/balena-intel/issues/283

Can you confirm that the WiFi works for your device as well?

Kind regards,
Thodoris

Hey @thgreasi, thanks! Haven’t tested yet, I did saw that comment, but unfortunately, as we currently rely on openBalena for deployments, we are unable to use balenaOS 2.50. In any regards, using wifi is not really a (good) option for my use-case

I’m in a bit of a pickle right now: New hardware is incompatible, no ETA on openBalena for new supervisor versions support, unsure if a ethernet USB dongle will be compatible out of the box :frowning_face:

Hi, do you happen to have a wifi dongle with idVendor=148f, idProduct=5370, bcdDevice= 1.01 available? It is a Ralink wifi dongle which should work until open balena works on newer OS releases

And as for using a ethernet usb adapter, I am pretty sure that should work fine too.