Intel NUC 10th gen i7 won't boot balenaOS 2.50.1+rev1 image

I’m trying to install balenaOS v2.50.1+rev1 on an Intel NUC with a 10th Generation Intel Core i7-10710U (NUC10i7FNK1). I have flashed an SD Card, but when it boots I just get a single “underline” character on the screen and nothing further happens. Is there some incompatibility that would preclude this from working?

Hi there, what image are you trying to flash? Have you tried going through the getting started page for he NUC? (

I went through the steps indicated in Balena Cloud to setup an app and then add a device. The image indicated to download, which is the one I used, was balenaOS v2.50.1+rev1. When the NUC boots with this image, I just get what looks like a non-blinking underline cursor in the top left of the screen and it just sits there indefinitely, no SSD read/writes, or any sign of life.

@kinergy, do you see a device in the dashboard? If so, that indicates the device has provisioned successfully, and you should be able to SSH into the device from there. Unless you’ve downloaded the development version of the flasher image, you’ll not be able to access a prompt anyway, since the kernel cmdline in production images (non-development images) turns off the serial console.

No, the dashboard is still showing 0 devices. It really doesn’t get far at all. I burn the image to an SD Card, boot the NUC with it. Splat! Nothing happens.

Ah, fair enough then. I suspect something is wrong with the image then, it should proceed through the flashing steps which will definitely log to the screen (serial console out), during flashing. I suspect in this case the image is corrupted on the SD card; did you burn with etcher [1] (which does post-burn verification), or something more low level without verification, like dd?


I used Etcher, it did indeed do the verification step :slight_smile:

I used the development mode of the balenaOS image, I’ll try the production mode

If etcher passed it, it means the image did burn correctly, but then I would wonder whether the image downloaded correctly. I would say in fact, download a production image at the same version, and see if the md5sum for both files are identical or not.

md5 for development and production are different. I tried both now with Ethernet+WiFi enabled, both failed the same way. Now I will try production with ethernet only option.

no dice, production/ethernet version doesn’t work either, here’s the md5:
MD5 = 20d23579b0f900bcf85c2b26fdf20e42

The md5 should differ between production and development, but the md5 can be used to detect whether the older downloaded production image is different (corrupted) as compared with the recently downloaded production (with which it should share an identical md5).

With corruption ruled out, network causes are the next to check. I’d suggest running wireshark in that case, to try to see if perhaps DHCP is failing to allocate an IP for the NUC, or whether maybe there are problems with TCP or DNS for the device, etc. (this could depend on whether your network has restrictive firewalls which only allow traffic from known hosts of which the NUC isn’t one?)

I really don’t think networking issues are a concern, the NUC is plugged into the same wired network that other computers are plugged into and after installing Ubuntu 20.04 directly everything was fine. It must be some hardware compatibility issue. I also installed Ubuntu 16.04 today and there must be a compatibility issue there as well because after logging in, the computer just powers off instantaneously.

Here’s the specific hardware:

Intel NUC 10 Performance Kit – Intel Core i7 Processor (Sleek Chassis)

Samsung (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology

Samsung 32GB DDR4 2666MHz RAM Memory Module for Laptop Computers (260 Pin SODIMM, 1.2V) M471A4G43MB1

Hi, I’ve noticed that you mentioned that you flashed an SD card. Did you try provisioning it with a USB thumb drive? You may find more information in the following getting started guide:


Interesting point, the SD Card was plugged into a converter to USB-C, wasn’t using the SD Card slot on the NUC. I did install both Ubuntu 18 and Ubuntu 20 via the same method though.

It would be helpful if you could try to provision your image to a USB thumb drive, to make sure it’s not an SD card related issue.
Please let us know how it worked for you.


I’m new here, but having what seems to be a directly related issue.

I’m trying to get started with an Intel NUC (an older 8th gen system with a 2.5" hdd and Core i3). And with some minor differences, I’m getting to a very similar point.

I am using a USB, and have downloaded a current dev image (twice to be sure it wasn’t a download problem) which I configured in Cloud in the most basic of ways.

I am seeing the flash process start after a reboot where I remove the usb. It all gets to a point where it is doing the "expand resin-data partition” step, which takes a while. Then the screen goes blank and there is a single, non-blinking, underline in the top left, as described above.

There are very occasional disk accesses, so I’m not keen on turning it off, but the power LED is on, and nothing else appears to be happening. I can’t ping or ssh or scan to the device, and my dashboard shows it is still in post-provisioning. As I type it says it has been Online for 13 minutes, but the status hasn’t changed, otherwise.

I have done this all before, yesterday. Eventually I powered it off and back on, but it never moved past the post-provisioning stage.

I recently made a post in the Balena OS area, where I was trying to follow the getting started over there and ran into trouble. There I had a system which didn’t have a running balena-engine daemon (I was able to ssh in, however, and the booted screen was up). That was with the same verison of the OS, so that might indicate the nature of the problem here, as well. There is some more info in that post, if it helps.

Any advice would be appreciated. I love what I see here, but so far have been unable to get a device up and running to play with.

Update - two hours later and nothing changed. Going back over to the other thread. :slight_smile:

Take care,


hey there Liam, I have replied in your other post. let’s continue the conversation there. thanks

@Kinergy did you ever fix your issues

Hello everyone, I seem to be having the exact same issue, except I’ve booted it with an USB drive and the problem remains.

I have the same exact kit but i5 instead of i7, NUC10i5FNH.

More info, we are currently using openBalena to manage a fleet of devices at my work. Because of documented compatibility issues with recent supervisor versions, we are using balenaOS 2.47.1, but the problem remains with balenaCloud and latest version (2.50.1+rev1). I’m unable to provide any logs because the boot process simply won’t even start, all I get is a white cursor stuck on what would appear to be grub’s startup process, before showing boot options.

Furthermore, the same exact USB stick flashes and boots just fine on older NUCs, namely NUC7i5BNH and others.

Dunno what to do next :x