BalenaOS v2.113.4 won´t install on a Intel NUC11ATK

Good Day!

I´ve got a little problem with the actual BalenaOS. After creating the image thru the Balena Dashboard (Add new Device) it won´t boot like the previous version v2.108.19.

After booting from the freshly created USB stick there´s just a cursor blinking, as it was in the previous versions, but with the actual version there is no installation happening. The cursor would blink to the end of times.

When you reboot the NUC there is no installation of BalenaOS.

I´ve created the installation medium multiple times, also tried different USB sticks as different NUC´s.
v2.108.19 works as it should.

Secure Boot is disabled in Bios.

What am i missing?

1 Like

Hi @portalum,

Is it possible for you to update to a newer version of balenaOS? We have a known-issue in the version you’re attempting to install related to some updates we did recently, which we’ve resolved in recent updated versions of balenaOS. You should see v2.113.4 available for your device-type:

If my investigation proves incorrect and that doesn’t resolve things for you, can you also share more then about how you can tell the installation isn’t occurring? Is it that the device isn’t showing in balenaCloud after you’ve flashed it, or are there some logs or something else you’re seeing which indicate the device has only partially completed its installation?

I can confirm the issue on generic x86 image. The device boots into the os from stick but never starts to copy the content to the drive of the device. The issue also happens with older version shown. If I include “outdated versions” and use a version that worked before the issue is “solved”.
Again: The recommended images for x86 dont install balena at the moment!

Hi @the-real-kenna,

The installation never takes place and the device does not appear in New Devices. I insert the USB stick into the USB slot of the Intel NUC after creating it via Balena Dashboard. I selected Intel NUC as the device type for the installation media. Then I burned the selected image to the USB stick using Balena Etcher.

During the boot process itself on the Intel NUC a message “Booting Flash” appears… as it should. However, the NUC never turns off…the flashing cursor remains.

In the previous versions, the intel nuc has always turned itself off after successful installation.

To be exact: I have also seen with v2.108.19 only a blinking cursor and never the installation process itself. after the successful installation the NUC shut itself down I pulled the usb stick and restarted the nuc. After booting the intel NUC appears under new devices as it should be.

There are no logs because the installation did never happen…it is like @danielboe says.

Hi, would you be able to use a development image and log into the flasher image to obtain the journalctl logs?