Azulletech Byte3

Has anyone installed BalenaOS on an Azulletech Byte3 mini PC?

It is running a 64-bit Quad-Core Intel Apollo Lake processor. I tried to install the Intel NUC Balena image, but the Byte3 just hangs when I boot off the USB.

Hello,
Have you tried using a dev image?
Do you have a monitor plugged in? Do you see anything on it?

Yes, I used development image for v2.44.0+rev1
I have a monitor plugged in, when I boot of the Balena USB image I only have a blinking prompt.
I used the Intel NUC image… would I be better off trying the Intel Edison image?

The edison image won’t work for sure.
The NUC image is supposed to install balenaOS and reboot.
You need to remove the usb stick (or at least not boot on it) when it reboots.

Hmmm, that didn’t work for me. It still boots into Windows 10, so the Balena install did not work. I’m going to start over re-flashing my USB stick and try the Balena install again.

Have you successfully installed Balena on the Byte3 ?

No, I don’t have one.

Darn, I think I may be in uncharted waters here.

I’ve installed Balena on the Intel NUC and an OnLogic ML350 and those work just fine.

The Byte3 we bought seems to be pretty locked-down. It has a password on the BIOS that nobody in the office set, so I can’t set the boot drive from BIOS. So I had to boot Windows 10, then have Windows 10 designate the USB as a boot drive. Then it reboots and just goes to a single prompt.

I almost wonder if Windows 10 detects a non-Windows boot drive and modifies it not to boot.

I was able to boot into the EFI Shell… and the grub files are on fs3: … is there a way to boot grub from the EFI command line?

Hello,

Sorry I have no experience with this EFI shell and don’t have it available here.

Do you see grub with an unique “flash” menu entry when you boot the device from the usb stick?
Do you see the device appearing on the balena dashboard (it should appear while flashing if it is connected through Ethernet or has configured wifi credentials)?
If you have a dev image and a screen & keyboard connected to the device, we can try the following to see how Linux sees the Byte3’s internal storage:

  • press CTRL+ALT+F2
  • enter root as username, no password
  • ls -l /dev/disk/by-id should give you a list of block devices available.
  • there should be a /var/log/provisioning-progress.log file

Thank you for those tips zvin.

No, it doesn’t even get that far. It does not show any kind of menu… just a flashing underline prompt.

I submitted a linux install question to the Byte3 forum… maybe they will can give us a hint for getting linux onto this little PC. If I hear anything I will report back.

Well, I was not able to get BalenaOS installed on the Byte3.
Here are my notes for future reference in case anybody else tries this:

ESC to enter BIOS

  • factory default BIOS password is: 0000
  • NOTE: be careful about using a compact keyboard… The Byte3 NUMLOCK defaults to ON… I used an Adafruit compact keyboard, and when I thought I typed a 0, it was actually the numlock * , and did not work. Get a full size USB keyboard out of the cabinet and save yourself some headaches.

In the BIOS menu:

  • go to Chipset
    Common Function
    OS Selection -> Intel Linux
  • go to Boot
    Boot Option #1 -> select your USB stick with BalenaOS on it
  • F4 -> save and exit

However, I could not get the Balena install to work. It just reboots to a flashing prompt, like the BIOS is still preventing the GRUB on the USB to load. ( I tried burning the image using Etcher onto 2 different 8GB USB keys, but both had the same result.)

Last tested with image intel-nuc-2.45.1+rev2-dev-v10.3.7

Hi

Thank you for the effort you put into trying to make balenaOS working on the Byte3.
I created an internal issue for adding support to Azulletech Byte3, we’ll evaluate it, and we’ll keep you posted.

Best regards

federico

Hello,

If you would like to have a package tested on any of the Azulle devices please feel free to reach out. I can say that one of our clients has successfully used a Balena build on one of our Inspire units. Please let me know if there is any way we can assist and we will be happy to.

Regards,

Azulle Team

P.S. On the Byte3 the default BIOS password is indeed 0000.
There are a couple of values that will need to be changed in order for this OS to work (if at all).
(Del to enter BIOS)
BIOS -> Chipset-South Cluster Configuration -> Miscellaneous Configuration -> 8254 Clock Gating - Toggle this as we’ve found some Linux distros require it on, others off, while most newer builds don’t care)

BIOS -> Chipset -> Common Function -> OS Selection [Change to desired target: Intel/Linux in this case]