Balena NUC installer hangs on x86 Z370 motherboard

We’re running into an issue installing Balena one of our computers with an Intel Z370 chipset (Gigabyte Aorus Gaming Z370 Wifi) the OS installer seems to get stuck while booting the kernel

How can we further diagnose?

FWIW Ubuntu runs fine out of the box on this machine with current hardware/bios settings (defaults)


Hi @jayv, and welcome to the forum! A few questions for you:

Let us know how it goes for you!

All the best,

Thanks Hugh, I’ll see if we can get more information with a dev image and elevated logging,

So we just tried the latest dev image 2.58.6+rev1 of the new generic x86_64 image, adding the ignore_loglevel kernel param doesn’t change the output on the console (besides prefix with timestamps) the logs are the same as in the attached image.

Exact same result with the NUC image downloaded from the unmanaged versions link you posted.

Hi, could you please use loglevel=8 instead of ignore_loglevel and see whether you can get a more verbose output. Also how long have you been waiting for the boot process to continue?