Unable to add a device to uk-train-departure-display


I’m unable to add a device to my uk-train-departure-display dashboard.

I’m using a Pi Zero 2 W. I’ve made sure to select that (64bit) as the device type. I’ve also set a 2.4G Wi-Fi network.

I’m using the recommended version (2.105.21) and the ‘Production’ edition (I’ve also tried ‘Development’ with the same result).

I used BalenaEtcher to flash the SD card, and when I start the Pi Zero I can see the device show up as active on my Wi-Fi network. It never shows up on my Balena Dashboard though.

I’ve tried using a different SD card. I’ve also tried creating a brand new Balena account.

Any idea what might be wrong?


1 Like

Hello @orac_k9 welcome to the balena community!

Thanks for your message! Could you please confirm what device type did you select when you created the fleet on balenaCloud? Did you select Raspberry Pi Zero 2?



I selected ‘Raspberry Pi Zero 2 W (64bit)’ as the device type.

The board is a 2 W.


@orac_k9 if it doesn’t connect to the balena dashboard could be for multiple things.

Do you see any led blinking on the Pi? Is there any pattern? Not sure if this can helps → Troubleshooting - Balena Documentation