UK train station platform departure display

Hi,

I’m a total newbie but followed Chris Crocker-White’s instructions on this project and managed to get the display to pop up first time of asking. I was amazed!
Unfortunately the display doesn’t refresh. Eventually, after 30 mins or so, it just goes blank.
I don’t understand how I can have got so far for it to fail.
Any ideas?

Hey @spoons glad to hear you got this working without any trouble. There might be several causes for this, is there any error showing up on the web terminal? If you want you can “Grant support access” to the device from the dropdown in the device summary page. This means a balena support agent will be able to ssh into the device and inspect all the running containers to help you debug such issues. Please note that you also need to provide the device UUID once support access is enabled.

Thanks for getting back to me so quickly. I’ve granted support access as requested.

Hi @spoons ,

Thanks for granting support access, but we’ll also need the UUID of the device, or the full dashboard URL of it (it’ll be something like https://https://dashboard.balena-cloud.com/devices/1234567890/summary ) so we know which device to look at!

Thanks,

Heds

My UUID is aa0b07a31b4cf932f21d4ded83917537

I’m not seeing any errors in the log, I think.

Thanks, we’ll have a look and see if we can spot anything!

Hi again,

I’ve had a quick look, and both balenaOS and the service container are running correctly.

Given the symptoms you’re seeing, this sounds like it could possibly be an issue with the attached OLED screen. Is it on a hat or using soldered connections? Have you tried using a multimetre to ensure the connections are good and aren’t variable? Unfortunately I’m not familiar with this particular display, but there may be a test application for it that runs through system checks that might be useful.

Best regards,

Heds

Hi Heds,

I thought that could be the case as my soldering skills aren’t great and the fact that I got the correct data on the display albeit not refreshing. I’ve remade all the my soldered connections on the display, and the results are the same, so I suppose it could be at the Raspberry end, but my knowledge of the outputs there are next to zero too. I shall have another look and let you know if I sort it out.

Many thanks for having a look at it.

Hi,

No trouble at all; hopefully a quick check of the pins at each end of the connections might show a loose one which could be easily fixed!

Best regards,

Heds

SOLVED: There was a zero-ohm jumper that needed to be repositioned in order to enable the display for SPI communication, which I thought I’d done because the display worked. I remade the jumper with a blob of solder and… not only did the display work but it updated correctly too!