UK Trains App -- Pi Zero W not showing up (even with ethernet)

Hi there,
I’ve been trying to do this tutorial for quite a while:

I have not been able to see the pi show up at all. I have separated by 2/5G wifi; I have plugged it into the ethernet… I even blew one Pi up completely playing with the power supply!

I have tried my current Pi Zero W with PiOS and it works fine – but when I flash the uk train station thing, it never shows – in developer mode or not. Also, there is no output from the HDMI…

Could anyone help? I have spent so much time with so little reward so far :wink:

Greetings, @baleanex - and welcome to the forums!

Sorry to hear you’re having trouble with this project. While I haven’t built / deployed this project, specifically - I’ll do the best to help.

I’ll start with some basic questions (apologies if the answers are obvious):

Are you attempting to deploy using the “Deploy with Balena” button in the middle of the referenced blog post?

When you were trying the WiFi configuration – I assume you were entering your WiFi details (SSID and password) in the appropriate section under “Advanced Settings”?

It appears that this project requires a series of environment variables to be set (departure station, refresh time, etc) – but I wouldn’t expect any of these items to prevent the device from showing up in Balena Dashboard.

I’m a relative N00b myself, so again, just enumerating somet of the more basic things. Can you share what you see / experience after deploying?

There was a time when I considered building this project, to see if I could adapt it to BART here in the San Francisco bay area but since early 2020, my mass transit ridership has been way, way down. :slight_smile:

We’ll get it figured out - even if we have to pull in some of the big guns who will have far better questions to ask, logs to check, etc.



@baleanex Apologies, I misspoke above. The WiFi config comes when ‘adding the device’ as described in the blog post, and is NOT under “Advanced Settings”. Should look something like this?

I realize you said the device also failed to show up when connected via Ethernet. For that… I’ve no clue. :frowning:


Hello @baleanex remember that Pi Zero works only with WiFi 2.4Ghz! Did you try with it? it’s odd that you don’t see output from the HDMI. Could you please confirm the balenaOS version and from where are you installing the UK Trains App?



Hi everyone,
first off, thanks for your help.

I tried again! This time, I did get screen output and I am connected (via ethernet) to the internet (I can ping

However! The device doesn’t show up. And I keep getting the message “wlan0: link is not ready”.

I will try flashing the SD card again…

Tried flashing another SSD, now I get… “rebooting in 1 second” and then it reboots (in a loop).

Something about ‘dump stack’; ‘exception stack’

And what logs do you get on the display? can you show a picture?