Display for Train display

Does anyone have a spare display that will work or can tell me where to buy one in the Uk.
I did move the jumper and metered it - it was zero ohms.

I have double checked and buzzed out my wiring and thats ok too.

I bought 3 displays as recommended from the Ali Express site. But I am getting nothing on the display.
I am sure its the display itself but cannot prove it yet.

My pi is showing in Balena and I am accessing the API as I am getting warning’s about the number of API’s calls being made per day!

I wanted to give the displays away as Christmas presents…but thats looking unlikely. But anyway if anyone can point me in the right direction that would be helpful

Hi Jack,

Can you provide some more detail about what you’re trying to build? What kind of RPi are you using? Are you connecting displays via on-board video? HDMI?


Hi I am trying to make the RPI Zero work with the Train display project.

The RPi does hsow up correctly in the Balena page as being on-line and the output should show on my 2.8 inch OLED displays . But I get nothing on the display at all. I tired with 2 displays that I got from the same source.

It does not appear to be a wiring issue, I have checked the wiring a few times with a meter too - just to be sure its correct.

I am getting notes from the API web site warning me I am hitting their API alot. So thats good.

Just nothing on the display, so I decided its the display

I am NOT using the HDMI output on the pi. Never tried that.

Well, it might be worth trying to hook up to HDMI and see if there is any output there, as a good test.

Alternatively, I do have to wonder if you can somehow test the OLED displays themselves by simply flashing Raspbian to an SD Card and attempting to run some sample Python that makes use of the OLED. Double check that the units you received from AliExpress are in fact the correct part, which is an SSD1322 256x64. And if so, perhaps this will work to test it: https://github.com/topherCantrell/ER-OLEDM032-1/blob/master/src/RPI_OLED.py

(Fair warning, I don’t have these parts, so, this is untested and just an idea).


Do NOT be tempted to use slow memory cards.

I believe the combination of slow card and the slow wi-fi connectivity on the zero, means you will get time-outs when loading the app onto the memory card.

Better to use quality cards - they do not need to be large capacity.

Remember when switching cards to re-power the RPi - otheriwse the interface between the display and card will not be initialised correctly.

Hi Jack,

Could you perhaps elaborate a bit more? Was that the cause of the issue you were having? Maybe you could share the steps you followed to get the display working? Cheers.

yes, the problem was reported on the Balena log file of:
38852be7f64b025319209a0’ due to ‘connect ECONNREFUSED /var/run/balena-engine.sock’
12.01.21 14:52:42 (+0000) Supervisor starting
12.01.21 14:52:58 (+0000) Downloading image ‘registry2.balena-cloud.com/v2/648472037786bd88388338795668e19e@sha256:166e52c6e43980e803cfa78cf0e768342974a40f438852be7f64b025319209a0
12.01.21 14:58:09 (+0000) Failed to download image ‘registry2.balena-cloud.com/v2/648472037786bd88388338795668e19e@sha256:166e52c6e43980e803cfa78cf0e768342974a40f438852be7f64b025319209a0’ due to ‘connect ECONNREFUSED /var/run/balena-engine.sock’
12.01.21 15:01:20 (+0000) Supervisor starting
12.01.21 15:01:35 (+0000) Downloading image 'registry2.balena-cloud.com/v2/648472037786bd88388338795668e19e@sha256:166e52c6e43980e803cfa78cf0e768342974a40f438852be

I checked on my wifi dashboard and the connection was very slow.
I expected slow connections as the RPi Zero does not support 5GHz connectivity.

I then tried using a good quality memory card ( Class 10 San disk Ultra) and the same hardware with the same connections between the OLED display, my wifi and the RPi Zero burst into life.

As I said before, the display did not come alive on its own, but required a power cycle to the RPi AND the display ( which is fed from the RPi anyway) to work.

Very very pleased with the result.

Oh, I see. Thank you for sharing the details. Glad you got it working!

I think your assesment is correct. Engine issues (the ECONNREFUSED error) can be caused by SD card errors, that is one of the reasons we recommend using quality SD cards.


Although I had everything working - something has changed and as I don’t have access to the code wondered what it actually meant:
My RPi Zero is online and copies the original code over from the memory card.
Upon rebooting I get this error - re-powering still gives this error - what does it mean?
I have tried a few different RPi’s all doing the same thing. Tried re-formatting the memory card and re-downloading and burning with Etcher - still no luck.

The error is shown

19.01.21 15:19:07 (+0000) Service exited 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:14 (+0000) Restarting service 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:03 (+0000)  main  Error: Expecting value: line 2 column 1 (char 1)
19.01.21 15:19:20 (+0000)  main  Error: Expecting value: line 2 column 1 (char 1)
19.01.21 15:19:24 (+0000) Service exited 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:32 (+0000) Restarting service 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:20 (+0000)  main  Error: Expecting value: line 2 column 1 (char 1)
19.01.21 15:19:38 (+0000)  main  Error: Expecting value: line 2 column 1 (char 1)
19.01.21 15:19:43 (+0000) Service exited 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:55 (+0000) Restarting service 'main sha256:891e5f1484de4baad32a970350d7846829e6c1ca38f78d06a56728eb93831ff0'
19.01.21 15:19:38 (+0000)  main  Error: Expecting value: line 2 column 1 (char 1)


Seems like there’s an error with parsing a json file in your setup. This makes the python script exit, which causes the service to restart. This goes on in a loop.

To figure what’s going on with the json - let’s take a look at the bash script that populates them with the right information here. As you can see it depends on some environment variables that need to be setup in the balenaCloud dashboard - as mentioned here

  • Can you confirm that you have all these values populated in the dashboard for the device? If possible do share a screenshot.
  • You said that you had it working and then it stopped. Did you do any changes to the configurations recently?
  • If both the above points are fine, I think we should look at the transport API and see if there have been any changes on that front which would break this on your device.