Two messages, two drives

Hi there. I’m trying to create a Mint flash drive on a ThinkPad running Windows 7. When I clicked to ‘select image’ I got the error message: ‘Missing partition table’. I chose ‘Continue’ rather than ‘Cancel’, inserted a flash drive, selected it as the target and clicked ‘Flash’. After a pause, I got another error message: ‘Attention. The writer process finished unexpectedly. Please try again, and contact the Etcher team if the problem persists.’ I clicked ‘retry’ to no avail. I took the drive out and reinserted it: the computer said it needed reformatting, but the reformat failed. I tried to reformat it on a Mac, but that failed, too. I put a DVD in the drive, but the Etcher couldn’t see it (two different DVDs, actually, to be on the safe side. I inserted a different flash drive, but got the same error messages and that drive, too, cannot be reformatted. Any suggestions?

Hi, would you try erasing your drive using the instructions we prepared in balenaEtcher repo on GitHub?

I see you’ve already tried reformatting the disk, but maybe following those specific instructions for Windows will help.
Please let us know if it worked.

Thanks for getting back to me, but I don’t think I understand you (I’m just a writer who uses computers in my work without understanding them, depending on an operating system that is no longer supported). Anyway, I downloaded the Windows USB/DVD Download Tool and ran it. When I clicked it on my Mint ISO file (linuxmint-19.3-cinnamon-64bit.iso) I got the error message: ‘the selected file is not a valid ISO file. Please select a valid ISO file and try again.’ I have no idea how to do this. Should I be contacting the Mint people about their file names? And in any case, will the Download Tool solve the problem of the unformattable flash drives?

@RolloM welcome to the forums :slight_smile:

It sounds like perhaps the ISO file that you’ve downloaded may have been corrupted in some way. You could verify everything is OK using the instructions on the Linux Mint website here: or alternatively simply try downloading it again.

You should not get the message ‘Missing partition table’ from Etcher with a valid ISO, nor should you see the ‘Please select a valid ISO file’ message with the Windows tool.

Thanks for the input. I’ll check the file the ways you suggest. If I fix it, should I be using the Etcher or the Download Tool to stick it on the flash drive or DVD. And do you have any ideas on how to revive the flash drives?

@RolloM if you’re still trying to use the flash drives for a Linux Mint installation, flashing them with a valid image using Etcher should get them working. Bear in mind Windows cannot read the Linux filesystems that Etcher will load onto the stick, so they won’t be readable under Windows even if they have been successfully flashed.

If you do want to restore them and use them as storage devices after flashing images like this, check out this link:

When I put one of the drives into the computer it told me it needed to be formatted, which I tried but the formatting failed. With the other drive, the computer shows no sign that it knows it exists. Assuming I can get the Mint file sorted out, should I get the Etcher to put them on one of these drives as it stands, or try to restore them on the Microsoft web site you gave me first?

@RolloM, yes as you’ve found Windows is not going to be able to recover them as simply as that, because it just cannot work with these filesystems out of the box. If you can sort out the Linux ISO you can write this with Etcher to the drive as it stands without having to worry about restoring it. It’s only if you want to start using these drives for storage under Windows that you’ll have to follow that Microsoft link.

OK. Thanks for bringing me this far. It’s getting late here (UK) so I’ll do the fixing in the morning. With any luck I’ll have good news to report tomorrow.

No progress, I’m afraid. I’ve downloaded a new ISO file and given it the Mint authenticity and integrity tests. I re-started the computer. I uninstalled and reinstalled the Etcher program. But I still get exactly the same error messages and the Etcher still can’t see when I put a DVD in it, though it recognizes the flash drive. And the Windows 7 USB/DVD download tool still says neither of my ISO files are valid.

Etcher still can’t see when I put a DVD in it

That’s because Etcher can’t flash DVDs.

As for the image, I’m afraid there’s little we can do. If it comes with a zip file, you might want to try selecting the zip file instead or, viceversa, if the zip file is giving you the error, try extracting the image and selecting it directly

OK. Thanks for your help.

No zip file. I have an Amazon Fire, so my plan is to switch off the connection between the ThinkPad and the internet, and use the Fire for surfing and emails.

Thanks again.