3 Drives I have tried to create bootable media on are now read only, but there is nothing to read

Have I broken my flash drives and SD card beyond repair? Every time I try download the mint linux ISO to them, as soon as it says it finished successfully, I get popups saying I need to format the disk before use (as in suddenly it is recognized as unusable?) When windows asks me to format it and I hit start (quick format or not) it says the disk is write protected. I can see that the drive is there on my file directory, but it doesn’t detect the size of the drive at all. Clicking it asks to format it, but if you cancel that window it says “D:\ is not accessible
The volume does not contain a recognized file system.
Please make sure that all required file system drivers are loaded and that the volume is not corrupted.”

I have already gone through this: How to Fix the Disk Is Write Protected USB Error and got to the last fix where there was no “StorageDevicePolicies” directory in my registry at all.

Is there any way I can get functionality of these back? How could this happen, could it be that I was trying to download the wrong file as bootable media?


flashing a linux mint ISO to the drive means you will have linux partitions on the device.
Windows by default is not able to handle linux partitons.
You can simply ignore the windows alerts about formatting “the not usable” drives.
I guess you want to boot and install linux mint, so after etcher says flash successful continue and try to boot from the sdcard.

The link you shared has good information on how to “reset” the drive.
Here Etcher broke my USB stick … or did it? is a similar guide in case you want to use the storage again in windows.

It wasn’t able to boot it either but making the drive with rufus worked.

Late response, but I spent hours trying to fix my Patriot USB key. I tried Disk Management, Diskpart, Rufus, and many low level format softwares. I found the one that works, EMTEC’s Restory utility:

It cost nothing and it works. Plug in your usb drive, open restore.exe, click “restore,” wait a couple minutes and voila!