Start Terminal - new issue?

Hi all, I’ve been working in resin staging (for support of multiple network interfaces). I noticed recently (not quite sure how recently), that I can no longer start a terminal from the Web UI. I consistently get:

Connection error

This happens with brand new provisioned devices as well as existing (all RPI3s). Anything new happen recently?

Everything else worked as expected (as far as I can tell).

Yes, can see this, just like the web terminal, also cannot connect with resin-cli. Pinged our engineers about this, and let you know when there’s more info. Thanks a lot for reporting! :muscle:

@mtwomey the issue was identified and fixed now! :ballot_box_with_check: The VPN was missing a key, needed to be reloaded with the right config.

Thanks again for reporting it and testing staging. :trophy:

Thanks! Working now :slight_smile:

I just noticed a new issue though - I had a device get “stuck” on the resin (staging) dashboard. The device got a new IP address (DHCP) and the dashboard kept thinking it was it’s old IP address. I tried powering it off for several minutes (until it indicated ‘Offline’ then powering it back on. It kept coming back online showing the old (and incorrect) IP address. This prevented any sort of action on the device - terminal, resetting it, no logs show up, …etc.

I was able to connect to the device locally (using the correct / new IP), yet the console continued to hang on to that old address. Ultimately I destroyed and rebuilt it.

Have you ever run into anything like this and is there a way to some how force this to “refresh”?

I’ve also had a device get “Stuck” when it came online with a different IP than before. I had to delete the device and start it again.

Hi @nealvs, I’m not sure I understand, get stuck with the terminal? Is this the same issue as mentioned above, or a different one?

I’m referring to mtwomey’s comment directly above mine.

Ah, got it :thumbsup: , let’s see if we can duplicate this, as it does not look pleasant.

@nealvs @mtwomey, asked the team, and the current guess we have is that the device might have hit a known bug that stops the resin supervisor from starting up. If it happens the next time, let us know and we’d love to check the device out and investigate :mag_right: If indeed that is the bug that we think it is, we should have fixes in place soon (if I understand correctly, it’s a quirky Docker bug, but not 100%).

Ok, I’ll keep an eye out for it happening again and let you know. When this happened, the device did show it was “Online”, so it doesn’t appear to be a “complete failure” of the supervisor, it’s just reporting it’s previous IP for some reason.