Device not sending info to but my app works


Hi there!

I have a device here:
it shows as Online, but it says "No logs yet"
My app works and responds ok.

I pushed a new commit and it is not updating.

something seems to be broken with the resin vpn perhaps?

I did an api reboot, my app showed a downtime then started working again, but the status in resin dashboard didn’t update.


:speech_balloon:hi there! if the restart functionality worked, and the device is correctly shown online, then the VPN is functioning fine. The lack of logs seems to be the concerning part here. Are you sure your network is not blocking pubnub for whatever reason?


I can’t be sure it is on a customer network.
there are other 3 devices on the same network I pushed a new commit and I think this one is not even downloading


@diegosucaria, I am trying to sum up the problem, you have 6 devices, by their IP addresses I believe 5 are on the same network and 1, which is the most stable is on a different subnet.

All the 6 run the same exact SW. One device of the 5 can’t be accessed from the dashboard and you see “No logs yet” and cannot reboot it or open a terminal.

When you said that you did reboot it was within your APP where you call the supervisor API directly:

curl -X POST --header "Content-Type:application/json" \

You mentioned that you can interact with all the devices from your backend server using google pubsub.

Am I missing something from our 1x1 thread?


No, it is a good sum up!

One correction, is that there are only 4 devices on the same network.

Small note: the device that “shows no logs” and can’t communicate trough resin dashboard has been like that from a while, like months ago. it started to be a problem today when I triggered an update (pushed a new commit) and it did not update.


:speech_balloon:As an additional question, have you tried to use the web terminal on the offending device? does it work?


it doesn’t work either.


:speech_balloon:Ah, I see. Do you mind leaving the device online? We’ll try to go deeper into it as soon as the team is back from the weekend.


yes, but unfortunately since my other problem which is not 100% related to this issue I will be going to physically upgrade the devices and will update to resin 2.x too.

I plan to do this tomorrow morning, that is 12-15 hours from now, perhaps I can wait a couple of extra hours!


:speech_balloon:I suspect any issue you may have here will persist with 2.x if it’s of the class we’re discussing, so please go ahead and update to 2.x. If the issue is still there, we will investigate further.


Hi @diegosucaria - The docker daemon on the device hit a bug ( causing the supervisor on the device to be stuck. I have gone ahead and fixed the issue on the device. We have issued a fix for this particular bug in resinOS 1.26, so if you wish to avoid this issue in the future, you can upgrade this device to ResinOS 1.26. This can be done by navigating to the devices “Actions” page and clicking on the action that says “ResinOS Update”, this will give you an interactive prompt and you can select resinOS 1.26 from the list.


Thank you! I see it working correctly now on the dashboard!