ERROR: resin failed to start


I’ve been using resin on a Raspberry Pi 3. Latest OS (2.7.5) and supervisor (6.3.6).
If I power cycle the RPi a few times, especially if I don’t wait for it to boot up the OS / application completely, occasionally I get this error in the log:

20.11.17 01:06:52 (-0200)  * Starting User Application ...
20.11.17 01:06:52 (-0200)  * start-stop-daemon: /etc/ is already running
20.11.17 01:06:52 (-0200)  [ !! ]
20.11.17 01:06:52 (-0200)  * ERROR: resin failed to start

It gets stuck there. The application just doesn’t start, no matter how much I wait.
If I restart the application from Resin’s dashboard, things go back to normal.

Can someone elaborate on the nature of the error, and how can I prevent the boot process from getting stuck?

Best regards.

@ymaia, Hi, I think we did not answer earlier as the thread was not in the Troubleshooting section, but I moved it there now.

Are you using Alpine base image for you application?

There was a recent fix, which targeted such an issue:

If it is Alpine, using the latest base image should resolve this.

Hi @majorz

Exactly. I’m running Alpine.
So, all I have to do is to issue a “git push” in order to have my application built again (now incorporating the fix), right?

Thank you!

Yes, if you have not specified an explicit docker image tag for the Alpine base image it should default to latest and a git push will pull the new version from the docker registry, which will be used during the build stage.
Please let us know how that worked for you :slight_smile:


Actually, I’m using:
FROM resin/%%RESIN_MACHINE_NAME%%-alpine-node:8-slim

Let me know if this won’t include the fix, for some reason.
I’ll begin testing immediately and let you know how it goes.

Thank you.

Yes, I just checked and the 8-slim tagged version was updated 5 days ago and should include the fix.
Good luck!

It works! I wasn’t able to reproduce the problem after the update.

1 Like

Excellent! Thanks for letting us know that it worked.