Seems to hang when using with an SD card

When I try to use Etcher 1.3.1 to copy the Raspian .img file to a newly formatted SD (formatted with SD Formatter), it just sits there saying “Starting”.
It’s been like this for about 90mins now. It is the second SD card I’ve tried with the same result. I’ve done the Windows box allowing the program to modify etc.
Does anyone know what could be causing this?

Hi there, this is a known issue unfortunately, but has been fixed in and will ship in the next release (which is just around the corner).
As a workaround, you can try running Etcher as Administrator – that has “fixed” it for quite a few people.

If by “next release” you mean 1.4.4, this problem has not been resolved. I just used 1.4.4 to burn an SD card under Win7(64) and had exactly the same repeatable problem (“Starting…” with no progress). It was repeatable because I found the previous report and tried a second time using “Run as Administrator” with exactly the same results.

Please provide a work-around.

I too have this with release 1.4.4
It worked just once, but now hangs at ‘starting’ even if I run as administrator.

Same with me. Version 1.4.4 running on High Sierra, worked once and now hangs at “Starting…”. I also tried starting it as root from the command line, but that made no difference.
I’ve also tried downgrading to 1.4.3 - that also made no difference.
Another data point: I’ve used the dd command to successfully (though very slowly) burn the same image file to the same sd card that failed with Etcher 1.4.4 & 1.4.3.