SD card rewritten after deleting partitions


I used balenaEtcher to flash hassios, and now my SD card cannot be written. I tried the instructions suggested at: on Windows and Linux and both failed. On Windows I get an error of a timeout on the ‘create parition primary’ step. On Linux i get this message (the last number differs between runs):

$ sudo dd if=/dev/zero of=/dev/sdb bs=512 count=1 conv=notrunc
1+0 records in
1+0 records out
512 bytes copied, 0.00685521 s, 74.7 kB/s

On gdisk i can see that the SD card has 8 partitions:

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048           67583   32.0 MiB    0C01  hassos-boot
   2           67584          116735   24.0 MiB    8300  hassos-kernel0
   3          116736          641023   256.0 MiB   8300  hassos-system0
   4          641024          690175   24.0 MiB    8300  hassos-kernel1
   5          690176         1214463   256.0 MiB   8300  hassos-system1
   6         1214464         1230847   8.0 MiB     8300  hassos-bootstate
   7         1230848         1427455   96.0 MiB    8300  hassos-overlay
   8         1427456        31422430   14.3 GiB    8300  hassos-data

Would highly appreciate your comments.

(tried first with balenaEtcher 1.5.109-linux-x64, then after the problems started with 1.5.111-linux-x64 but no solution found yet). (It would seem to me that the programs actually execute the commands i call but then content gets to be re-written, see gif



It looks like the card is possibly corrupted. Have you tried this in a different reader, or machine, by chance? Also, did the card work fine with the hassios image when you flashed it?

Hi, yes i’ve tried other ‘balenaEtcher’ software-like, but all prompt messages of no success

i’m not sure on this. first i flashed a 32-bit version of hassios, then i tried it on the Raspberry-Pi but it boot for a moment and then just waited indefinitely on the installation phase, and so after that i tried with a 64-bit version and had same outcome, so now i’m checking if the card works correctly

Let us know your findings then. If you have a different sdcard and card reader (or usb slot) to use, changing them could also help in case one of them is the problem in the cycle