etcher destroys SD cards

I set up several SD-Cards (mini and micro) with the “help” of etcher!
They are ALL not any more useable for any other usage!
I formatted 10times. I searched for solutions on the net; I found some hints, which did partly, what I wanted: to reformat my SD-Cards to nil.
Never mind - but in this way I lost 10 SDs - almost 120dollars worth.
never again I will use etcher - and I tell my friends too


I’m sorry to read that you had such experience… what exact problem did you experience? did you get any error?

I have the same problem. I ran your belenaEtcher on my USB on my Mac. Afterward, the USB is no longer recognizable by Mac; not readable.

Hi there, please take a look at this blog post: It contains an explanation and instructions on how to “recover” SD/USB drives that appear to be damaged. Let us know if that helps!

I am also having same problem in windows. i have corrupted two sd cards so far while flashing Ubuntu for raspberry pi. I have followed all guides but still no luck getting those cards back .Windows does not even detects card as a device and does not shows as a disk in Diskpart.exe . I have even tried in Linux(pc) and it also does not recognises the card. Please help!

Hi @bhoopendrau

thanks, dmesg -wH was showing no change during inserting SD card reader hence i changed my sd card reader and both cards started showing up as unallocated space.