Running BalenaEtcher with Windows 10 Pro 64bit

I installed originally BalenaEtcher 1.5.70 on Dec 29, 2019. Since then I have burned a couple ISO files.
This morning I tried to copy an ISO to a jump drive and the window was blank. I waited for awhile and nothing. I moved the window and there was another blank window.
I went to Balena’s website and downloaded BalenaEtcher-setup-1.5.106. Now there is no blank screen and nothing works. If I go to the task manager I have three process called balena running, but the software doesn’t do anything. My Windows 10 Pro is version 10.0.18363


Can you try completely uninstalling all instances of etcher, killing the tasks in task manager, and reinstalling Etcher? Does this happen even then?

Also see c:\users\<user>\AppData\Local\Programs\balenaEtcher after removing

After removing completely BalenaEtcher I went to the filepath you suggested and the balenaEtcher was not there.
There may be a left over in the registry. Not sure.
Either way new install doesn’t initiate the GUI even though the processes are running.


  • Could you end all the processes related to etcher and try to open it again?

  • When you open it, could you press Ctrl+Shift+I, navigate to the “Console” pane on that new window and copy-paste all the information you see in there?

Such application logs might help us figure out what is the issue!

Hi Mahmoud,I am not sure what you mean by Ctrl+Shift+I. If you are after the balenaEtcher.DMP file, I can do that from the task manager.

Hi Carlos

Mahmoud refers to the Etcher console logs. If you open etcher, focus into the window, and press Ctrl+Shift+I the DevTools window will appear. In there, navigate to the “Console” pane and copy-paste all the information you see.

That information will be very useful for us to debug the issue :slight_smile:

There is no window. The processes run in the background, but it never initialized the GUI. I cannot focus on the window. I stopped all balena processes in task manager, and launched etcher. Immediately I see three processes in TM but the window doesn’t even inititialize.

Hi Carlos, can you please try to run Etcher from cmd.exe? this way you will get the logs my team-mates were referring to.


If I run the app from the command prompt, I receive the following error message:
(node:14704) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.

Hello Carlos, those are just warnings that the app prints on startup, are there no other logs appearing in the console after that?

No. Nothing else. Do you have some sort of config file that dumps information to a file for troubleshooting purposes?

Carlos Henrique Barberino

There’s no other place to look for the logs. Do any other electron application work on this computer ?

Apparently BalenaEtcher has some problems with Acronis Active Protection. Is I turn active protection off I can open BalenaEtcher.
My suggestion is that you find out what is causing Acronis to stop your GUI and allow the processes in task manager to run in BG.

Carlos Henrique Barberino

Hey Carlos, For the time being you can disable Acronis and flash as needed. I’ll open an issue about this just so we can track it, but I am not sure if there is anything that can be done, our team can investigate when they find the time.